Console problems

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|

Console problems

Luitpold Hingerl
Dear JGrass users,
I have a problem running the console.
It's not possible to run any command, I always get the following error
message:
"Parse error at line 1, column 8.  Encountered: static"

This is my setting in the Editor:

/*
 *  Welcome to the JGrass ConsoleEngine Editor
 *
 *  The editor supports the groovy scripting language
 *  as well as the JGrass Modeling language based on
 *  OpenMI standards merged with the OGC feature model
 *  supplied by UDig.
 *
 *  To execute a script right click in the editor area
 *  and first set the runtime preferences, some of which
 *  are configurable in the global preferences.
 *  After that you can execute the script.
 */
//Please uncomment and define the following options if needed:
# MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
# GISBASE= opt/grass
//# STARTDATE = 2009-08-03 06:00
//# ENDDATE = 2009-08-06 12:00
//# DELTAT= 30
//# RT= usually not needed
//# DEBUG= false
//# TRACE= false
//# NATIVEDEBUG= false
jgrass {h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
--threshold 100 --ograss-net net.100}

Any suggestions?
Thanks for your help!
Regards,

Poldi

_______________________________________________
JGrass-users mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
Reply | Threaded
Open this post in threaded view
|

Re: Console problems

Andrea Antonello
Hi Poldi,
some comments inline:

> I have a problem running the console.
> It's not possible to run any command, I always get the following error
> message:
> "Parse error at line 1, column 8.  Encountered: static"
[...]
> //Please uncomment and define the following options if needed:
> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
> # GISBASE= opt/grass

this should not be the problem, but it should be /opt/grass

> //# STARTDATE = 2009-08-03 06:00
> //# ENDDATE = 2009-08-06 12:00
> //# DELTAT= 30
> //# RT= usually not needed
> //# DEBUG= false
> //# TRACE= false
> //# NATIVEDEBUG= false
> jgrass {h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
> --threshold 100 --ograss-net net.100}

Can you try it out with spaces from the brackets?
i.e:
jgrass {
  h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
--threshold 100 --ograss-net net.100
}


Let me know if it solves,
Andrea


>
> Any suggestions?
> Thanks for your help!
> Regards,
>
> Poldi
>
> _______________________________________________
> JGrass-users mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>
_______________________________________________
JGrass-users mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
Reply | Threaded
Open this post in threaded view
|

Re: Console problems

Luitpold Hingerl
Hi Andrea,

thank you very much for your fast answer.
Unfortunately the spaces didn't solve the problem, I still get the samer
error message...
Do you have any other idea?

Greets,

Poldi


andrea antonello wrote:

> Hi Poldi,
> some comments inline:
>
>> I have a problem running the console.
>> It's not possible to run any command, I always get the following error
>> message:
>> "Parse error at line 1, column 8.  Encountered: static"
> [...]
>> //Please uncomment and define the following options if needed:
>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>> # GISBASE= opt/grass
>
> this should not be the problem, but it should be /opt/grass
>
>> //# STARTDATE = 2009-08-03 06:00
>> //# ENDDATE = 2009-08-06 12:00
>> //# DELTAT= 30
>> //# RT= usually not needed
>> //# DEBUG= false
>> //# TRACE= false
>> //# NATIVEDEBUG= false
>> jgrass {h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>> --threshold 100 --ograss-net net.100}


> Can you try it out with spaces from the brackets?
> i.e:
> jgrass {
>   h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
> --threshold 100 --ograss-net net.100
> }
>
>
> Let me know if it solves,
> Andrea
>
>
>> Any suggestions?
>> Thanks for your help!
>> Regards,
>>
>> Poldi
>>
>> _______________________________________________
>> JGrass-users mailing list
>> [hidden email]
>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>
> _______________________________________________
> JGrass-users mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users

_______________________________________________
JGrass-users mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
Reply | Threaded
Open this post in threaded view
|

Re: Console problems

Andrea Antonello
Hi Poldi,
are you using the last version available on the jgrass site?

Also, could you please try to execute some simple scripts and tell me
if they work?

script 1:

# MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
# GISBASE= /opt/grass

println "test"


script 2:

# MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
# GISBASE= /opt/grass

grass g.region --help


script 3:

# MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
# GISBASE= /opt/grass

jgrass {
h.extractnetwork --help
}



Also could you please paste me the whole error message?


Andrea



On Wed, Jul 29, 2009 at 2:21 PM, Luitpold
Hingerl<[hidden email]> wrote:

> Hi Andrea,
>
> thank you very much for your fast answer.
> Unfortunately the spaces didn't solve the problem, I still get the samer
> error message...
> Do you have any other idea?
>
> Greets,
>
> Poldi
>
>
> andrea antonello wrote:
>> Hi Poldi,
>> some comments inline:
>>
>>> I have a problem running the console.
>>> It's not possible to run any command, I always get the following error
>>> message:
>>> "Parse error at line 1, column 8.  Encountered: static"
>> [...]
>>> //Please uncomment and define the following options if needed:
>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>> # GISBASE= opt/grass
>>
>> this should not be the problem, but it should be /opt/grass
>>
>>> //# STARTDATE = 2009-08-03 06:00
>>> //# ENDDATE = 2009-08-06 12:00
>>> //# DELTAT= 30
>>> //# RT= usually not needed
>>> //# DEBUG= false
>>> //# TRACE= false
>>> //# NATIVEDEBUG= false
>>> jgrass {h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>> --threshold 100 --ograss-net net.100}
>
>
>> Can you try it out with spaces from the brackets?
>> i.e:
>> jgrass {
>>   h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>> --threshold 100 --ograss-net net.100
>> }
>>
>>
>> Let me know if it solves,
>> Andrea
>>
>>
>>> Any suggestions?
>>> Thanks for your help!
>>> Regards,
>>>
>>> Poldi
>>>
>>> _______________________________________________
>>> JGrass-users mailing list
>>> [hidden email]
>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>
>> _______________________________________________
>> JGrass-users mailing list
>> [hidden email]
>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>
> _______________________________________________
> JGrass-users mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>
_______________________________________________
JGrass-users mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
Reply | Threaded
Open this post in threaded view
|

Re: Console problems

Luitpold Hingerl
Hi Andrea,
I have the version 1.1.0. I think it is the newest isn't it?
This was theo whole error message look:

JGrass 2 Console ML (Model Language) Compiler, Version 1.0.0.832, for i386
Copyright (C)
        HydroloGIS - www.hydrologis.com,
        C.U.D.A.M. - http://www.unitn.it/dipartimenti/cudam
-------------------------------- Compiling...
---------------------------------
default.jgrass
default.jgrass - 1 model/s compiled, total compilation time: 242 ms

-------------------------------------------------------------------------------
Beanshell, Version 2.0b4, Copyright (C) Pat Niemeyer
------------------------------ Running model...
-------------------------------
Parse error at line 1, column 8.  Encountered: static

Total run time: 249 ms

I tried all your scripts but none of them works...

Poldi




andrea antonello wrote:

> Hi Poldi,
> are you using the last version available on the jgrass site?
>
> Also, could you please try to execute some simple scripts and tell me
> if they work?
>
> script 1:
>
> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
> # GISBASE= /opt/grass
>
> println "test"
>
>
> script 2:
>
> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
> # GISBASE= /opt/grass
>
> grass g.region --help
>
>
> script 3:
>
> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
> # GISBASE= /opt/grass
>
> jgrass {
> h.extractnetwork --help
> }
>
>
>
> Also could you please paste me the whole error message?
>
>
> Andrea
>
>
>
> On Wed, Jul 29, 2009 at 2:21 PM, Luitpold
> Hingerl<[hidden email]> wrote:
>> Hi Andrea,
>>
>> thank you very much for your fast answer.
>> Unfortunately the spaces didn't solve the problem, I still get the samer
>> error message...
>> Do you have any other idea?
>>
>> Greets,
>>
>> Poldi
>>
>>
>> andrea antonello wrote:
>>> Hi Poldi,
>>> some comments inline:
>>>
>>>> I have a problem running the console.
>>>> It's not possible to run any command, I always get the following error
>>>> message:
>>>> "Parse error at line 1, column 8.  Encountered: static"
>>> [...]
>>>> //Please uncomment and define the following options if needed:
>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>> # GISBASE= opt/grass
>>> this should not be the problem, but it should be /opt/grass
>>>
>>>> //# STARTDATE = 2009-08-03 06:00
>>>> //# ENDDATE = 2009-08-06 12:00
>>>> //# DELTAT= 30
>>>> //# RT= usually not needed
>>>> //# DEBUG= false
>>>> //# TRACE= false
>>>> //# NATIVEDEBUG= false
>>>> jgrass {h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>>> --threshold 100 --ograss-net net.100}
>>
>>> Can you try it out with spaces from the brackets?
>>> i.e:
>>> jgrass {
>>>   h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>> --threshold 100 --ograss-net net.100
>>> }
>>>
>>>
>>> Let me know if it solves,
>>> Andrea
>>>
>>>
>>>> Any suggestions?
>>>> Thanks for your help!
>>>> Regards,
>>>>
>>>> Poldi
>>>>
>>>> _______________________________________________
>>>> JGrass-users mailing list
>>>> [hidden email]
>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>
>>> _______________________________________________
>>> JGrass-users mailing list
>>> [hidden email]
>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>> _______________________________________________
>> JGrass-users mailing list
>> [hidden email]
>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>
> _______________________________________________
> JGrass-users mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users

_______________________________________________
JGrass-users mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
Reply | Threaded
Open this post in threaded view
|

Re: Console problems

Andrea Antonello
> I have the version 1.1.0. I think it is the newest isn't it?

1.1.0?

You installed through plugins into udig?
Didn't you take the last found here:
http://jgrass.wiki.software.bz.it/jgrass/Installation ?


Andrea


> This was theo whole error message look:
>
> JGrass 2 Console ML (Model Language) Compiler, Version 1.0.0.832, for i386
> Copyright (C)
>        HydroloGIS - www.hydrologis.com,
>        C.U.D.A.M. - http://www.unitn.it/dipartimenti/cudam
> -------------------------------- Compiling...
> ---------------------------------
> default.jgrass
> default.jgrass - 1 model/s compiled, total compilation time: 242 ms
>
> -------------------------------------------------------------------------------
> Beanshell, Version 2.0b4, Copyright (C) Pat Niemeyer
> ------------------------------ Running model...
> -------------------------------
> Parse error at line 1, column 8.  Encountered: static
>
> Total run time: 249 ms
>
> I tried all your scripts but none of them works...
>
> Poldi
>
>
>
>
> andrea antonello wrote:
>> Hi Poldi,
>> are you using the last version available on the jgrass site?
>>
>> Also, could you please try to execute some simple scripts and tell me
>> if they work?
>>
>> script 1:
>>
>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>> # GISBASE= /opt/grass
>>
>> println "test"
>>
>>
>> script 2:
>>
>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>> # GISBASE= /opt/grass
>>
>> grass g.region --help
>>
>>
>> script 3:
>>
>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>> # GISBASE= /opt/grass
>>
>> jgrass {
>> h.extractnetwork --help
>> }
>>
>>
>>
>> Also could you please paste me the whole error message?
>>
>>
>> Andrea
>>
>>
>>
>> On Wed, Jul 29, 2009 at 2:21 PM, Luitpold
>> Hingerl<[hidden email]> wrote:
>>> Hi Andrea,
>>>
>>> thank you very much for your fast answer.
>>> Unfortunately the spaces didn't solve the problem, I still get the samer
>>> error message...
>>> Do you have any other idea?
>>>
>>> Greets,
>>>
>>> Poldi
>>>
>>>
>>> andrea antonello wrote:
>>>> Hi Poldi,
>>>> some comments inline:
>>>>
>>>>> I have a problem running the console.
>>>>> It's not possible to run any command, I always get the following error
>>>>> message:
>>>>> "Parse error at line 1, column 8.  Encountered: static"
>>>> [...]
>>>>> //Please uncomment and define the following options if needed:
>>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>>> # GISBASE= opt/grass
>>>> this should not be the problem, but it should be /opt/grass
>>>>
>>>>> //# STARTDATE = 2009-08-03 06:00
>>>>> //# ENDDATE = 2009-08-06 12:00
>>>>> //# DELTAT= 30
>>>>> //# RT= usually not needed
>>>>> //# DEBUG= false
>>>>> //# TRACE= false
>>>>> //# NATIVEDEBUG= false
>>>>> jgrass {h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>>>> --threshold 100 --ograss-net net.100}
>>>
>>>> Can you try it out with spaces from the brackets?
>>>> i.e:
>>>> jgrass {
>>>>   h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>>> --threshold 100 --ograss-net net.100
>>>> }
>>>>
>>>>
>>>> Let me know if it solves,
>>>> Andrea
>>>>
>>>>
>>>>> Any suggestions?
>>>>> Thanks for your help!
>>>>> Regards,
>>>>>
>>>>> Poldi
>>>>>
>>>>> _______________________________________________
>>>>> JGrass-users mailing list
>>>>> [hidden email]
>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>>
>>>> _______________________________________________
>>>> JGrass-users mailing list
>>>> [hidden email]
>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>> _______________________________________________
>>> JGrass-users mailing list
>>> [hidden email]
>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>
>> _______________________________________________
>> JGrass-users mailing list
>> [hidden email]
>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>
> _______________________________________________
> JGrass-users mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>
_______________________________________________
JGrass-users mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
Reply | Threaded
Open this post in threaded view
|

Re: Console problems

Luitpold Hingerl
Yes thats where I downloaded this version about 3 month ago...
So this isn't the newest?
I'm sorry if I'm asking stupid questions...

Poldi


andrea antonello wrote:

>> I have the version 1.1.0. I think it is the newest isn't it?
>
> 1.1.0?
>
> You installed through plugins into udig?
> Didn't you take the last found here:
> http://jgrass.wiki.software.bz.it/jgrass/Installation ?
>
>
> Andrea
>
>
>> This was theo whole error message look:
>>
>> JGrass 2 Console ML (Model Language) Compiler, Version 1.0.0.832, for i386
>> Copyright (C)
>>        HydroloGIS - www.hydrologis.com,
>>        C.U.D.A.M. - http://www.unitn.it/dipartimenti/cudam
>> -------------------------------- Compiling...
>> ---------------------------------
>> default.jgrass
>> default.jgrass - 1 model/s compiled, total compilation time: 242 ms
>>
>> -------------------------------------------------------------------------------
>> Beanshell, Version 2.0b4, Copyright (C) Pat Niemeyer
>> ------------------------------ Running model...
>> -------------------------------
>> Parse error at line 1, column 8.  Encountered: static
>>
>> Total run time: 249 ms
>>
>> I tried all your scripts but none of them works...
>>
>> Poldi
>>
>>
>>
>>
>> andrea antonello wrote:
>>> Hi Poldi,
>>> are you using the last version available on the jgrass site?
>>>
>>> Also, could you please try to execute some simple scripts and tell me
>>> if they work?
>>>
>>> script 1:
>>>
>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>> # GISBASE= /opt/grass
>>>
>>> println "test"
>>>
>>>
>>> script 2:
>>>
>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>> # GISBASE= /opt/grass
>>>
>>> grass g.region --help
>>>
>>>
>>> script 3:
>>>
>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>> # GISBASE= /opt/grass
>>>
>>> jgrass {
>>> h.extractnetwork --help
>>> }
>>>
>>>
>>>
>>> Also could you please paste me the whole error message?
>>>
>>>
>>> Andrea
>>>
>>>
>>>
>>> On Wed, Jul 29, 2009 at 2:21 PM, Luitpold
>>> Hingerl<[hidden email]> wrote:
>>>> Hi Andrea,
>>>>
>>>> thank you very much for your fast answer.
>>>> Unfortunately the spaces didn't solve the problem, I still get the samer
>>>> error message...
>>>> Do you have any other idea?
>>>>
>>>> Greets,
>>>>
>>>> Poldi
>>>>
>>>>
>>>> andrea antonello wrote:
>>>>> Hi Poldi,
>>>>> some comments inline:
>>>>>
>>>>>> I have a problem running the console.
>>>>>> It's not possible to run any command, I always get the following error
>>>>>> message:
>>>>>> "Parse error at line 1, column 8.  Encountered: static"
>>>>> [...]
>>>>>> //Please uncomment and define the following options if needed:
>>>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>>>> # GISBASE= opt/grass
>>>>> this should not be the problem, but it should be /opt/grass
>>>>>
>>>>>> //# STARTDATE = 2009-08-03 06:00
>>>>>> //# ENDDATE = 2009-08-06 12:00
>>>>>> //# DELTAT= 30
>>>>>> //# RT= usually not needed
>>>>>> //# DEBUG= false
>>>>>> //# TRACE= false
>>>>>> //# NATIVEDEBUG= false
>>>>>> jgrass {h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>>>>> --threshold 100 --ograss-net net.100}
>>>>> Can you try it out with spaces from the brackets?
>>>>> i.e:
>>>>> jgrass {
>>>>>   h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>>>> --threshold 100 --ograss-net net.100
>>>>> }
>>>>>
>>>>>
>>>>> Let me know if it solves,
>>>>> Andrea
>>>>>
>>>>>
>>>>>> Any suggestions?
>>>>>> Thanks for your help!
>>>>>> Regards,
>>>>>>
>>>>>> Poldi
>>>>>>
>>>>>> _______________________________________________
>>>>>> JGrass-users mailing list
>>>>>> [hidden email]
>>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>>>
>>>>> _______________________________________________
>>>>> JGrass-users mailing list
>>>>> [hidden email]
>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>> _______________________________________________
>>>> JGrass-users mailing list
>>>> [hidden email]
>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>
>>> _______________________________________________
>>> JGrass-users mailing list
>>> [hidden email]
>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>> _______________________________________________
>> JGrass-users mailing list
>> [hidden email]
>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>
> _______________________________________________
> JGrass-users mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users

_______________________________________________
JGrass-users mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
Reply | Threaded
Open this post in threaded view
|

Re: Console problems

Andrea Antonello
Hi Poldi,
sorry for the delay. We have been quite busy.

Anyways I just created a new build with many bug fixes and some
improvements. I don't think that your problems are bound to the
version. But I am quite sure something dirty is going on in your
install. Would you mind to download the latest version and try to
reinstall, possibly be cleaning up your workspace (i.e. removing it)?

Ciao
Andrea




On Wed, Jul 29, 2009 at 4:31 PM, Luitpold
Hingerl<[hidden email]> wrote:

> Yes thats where I downloaded this version about 3 month ago...
> So this isn't the newest?
> I'm sorry if I'm asking stupid questions...
>
> Poldi
>
>
> andrea antonello wrote:
>>> I have the version 1.1.0. I think it is the newest isn't it?
>>
>> 1.1.0?
>>
>> You installed through plugins into udig?
>> Didn't you take the last found here:
>> http://jgrass.wiki.software.bz.it/jgrass/Installation ?
>>
>>
>> Andrea
>>
>>
>>> This was theo whole error message look:
>>>
>>> JGrass 2 Console ML (Model Language) Compiler, Version 1.0.0.832, for i386
>>> Copyright (C)
>>>        HydroloGIS - www.hydrologis.com,
>>>        C.U.D.A.M. - http://www.unitn.it/dipartimenti/cudam
>>> -------------------------------- Compiling...
>>> ---------------------------------
>>> default.jgrass
>>> default.jgrass - 1 model/s compiled, total compilation time: 242 ms
>>>
>>> -------------------------------------------------------------------------------
>>> Beanshell, Version 2.0b4, Copyright (C) Pat Niemeyer
>>> ------------------------------ Running model...
>>> -------------------------------
>>> Parse error at line 1, column 8.  Encountered: static
>>>
>>> Total run time: 249 ms
>>>
>>> I tried all your scripts but none of them works...
>>>
>>> Poldi
>>>
>>>
>>>
>>>
>>> andrea antonello wrote:
>>>> Hi Poldi,
>>>> are you using the last version available on the jgrass site?
>>>>
>>>> Also, could you please try to execute some simple scripts and tell me
>>>> if they work?
>>>>
>>>> script 1:
>>>>
>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>> # GISBASE= /opt/grass
>>>>
>>>> println "test"
>>>>
>>>>
>>>> script 2:
>>>>
>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>> # GISBASE= /opt/grass
>>>>
>>>> grass g.region --help
>>>>
>>>>
>>>> script 3:
>>>>
>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>> # GISBASE= /opt/grass
>>>>
>>>> jgrass {
>>>> h.extractnetwork --help
>>>> }
>>>>
>>>>
>>>>
>>>> Also could you please paste me the whole error message?
>>>>
>>>>
>>>> Andrea
>>>>
>>>>
>>>>
>>>> On Wed, Jul 29, 2009 at 2:21 PM, Luitpold
>>>> Hingerl<[hidden email]> wrote:
>>>>> Hi Andrea,
>>>>>
>>>>> thank you very much for your fast answer.
>>>>> Unfortunately the spaces didn't solve the problem, I still get the samer
>>>>> error message...
>>>>> Do you have any other idea?
>>>>>
>>>>> Greets,
>>>>>
>>>>> Poldi
>>>>>
>>>>>
>>>>> andrea antonello wrote:
>>>>>> Hi Poldi,
>>>>>> some comments inline:
>>>>>>
>>>>>>> I have a problem running the console.
>>>>>>> It's not possible to run any command, I always get the following error
>>>>>>> message:
>>>>>>> "Parse error at line 1, column 8.  Encountered: static"
>>>>>> [...]
>>>>>>> //Please uncomment and define the following options if needed:
>>>>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>>>>> # GISBASE= opt/grass
>>>>>> this should not be the problem, but it should be /opt/grass
>>>>>>
>>>>>>> //# STARTDATE = 2009-08-03 06:00
>>>>>>> //# ENDDATE = 2009-08-06 12:00
>>>>>>> //# DELTAT= 30
>>>>>>> //# RT= usually not needed
>>>>>>> //# DEBUG= false
>>>>>>> //# TRACE= false
>>>>>>> //# NATIVEDEBUG= false
>>>>>>> jgrass {h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>>>>>> --threshold 100 --ograss-net net.100}
>>>>>> Can you try it out with spaces from the brackets?
>>>>>> i.e:
>>>>>> jgrass {
>>>>>>   h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>>>>> --threshold 100 --ograss-net net.100
>>>>>> }
>>>>>>
>>>>>>
>>>>>> Let me know if it solves,
>>>>>> Andrea
>>>>>>
>>>>>>
>>>>>>> Any suggestions?
>>>>>>> Thanks for your help!
>>>>>>> Regards,
>>>>>>>
>>>>>>> Poldi
>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> JGrass-users mailing list
>>>>>>> [hidden email]
>>>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>>>>
>>>>>> _______________________________________________
>>>>>> JGrass-users mailing list
>>>>>> [hidden email]
>>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>> _______________________________________________
>>>>> JGrass-users mailing list
>>>>> [hidden email]
>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>>
>>>> _______________________________________________
>>>> JGrass-users mailing list
>>>> [hidden email]
>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>> _______________________________________________
>>> JGrass-users mailing list
>>> [hidden email]
>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>
>> _______________________________________________
>> JGrass-users mailing list
>> [hidden email]
>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>
> _______________________________________________
> JGrass-users mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>
_______________________________________________
JGrass-users mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
Reply | Threaded
Open this post in threaded view
|

Re: Console problems

Luitpold Hingerl
Hello Andrea,

thank you for your efforts!
I have downloaded and installed the newest version and now it works
properly.

Best wishes,

Poldi


andrea antonello wrote:

> Hi Poldi,
> sorry for the delay. We have been quite busy.
>
> Anyways I just created a new build with many bug fixes and some
> improvements. I don't think that your problems are bound to the
> version. But I am quite sure something dirty is going on in your
> install. Would you mind to download the latest version and try to
> reinstall, possibly be cleaning up your workspace (i.e. removing it)?
>
> Ciao
> Andrea
>
>
>
>
> On Wed, Jul 29, 2009 at 4:31 PM, Luitpold
> Hingerl<[hidden email]> wrote:
>> Yes thats where I downloaded this version about 3 month ago...
>> So this isn't the newest?
>> I'm sorry if I'm asking stupid questions...
>>
>> Poldi
>>
>>
>> andrea antonello wrote:
>>>> I have the version 1.1.0. I think it is the newest isn't it?
>>> 1.1.0?
>>>
>>> You installed through plugins into udig?
>>> Didn't you take the last found here:
>>> http://jgrass.wiki.software.bz.it/jgrass/Installation ?
>>>
>>>
>>> Andrea
>>>
>>>
>>>> This was theo whole error message look:
>>>>
>>>> JGrass 2 Console ML (Model Language) Compiler, Version 1.0.0.832, for i386
>>>> Copyright (C)
>>>>        HydroloGIS - www.hydrologis.com,
>>>>        C.U.D.A.M. - http://www.unitn.it/dipartimenti/cudam
>>>> -------------------------------- Compiling...
>>>> ---------------------------------
>>>> default.jgrass
>>>> default.jgrass - 1 model/s compiled, total compilation time: 242 ms
>>>>
>>>> -------------------------------------------------------------------------------
>>>> Beanshell, Version 2.0b4, Copyright (C) Pat Niemeyer
>>>> ------------------------------ Running model...
>>>> -------------------------------
>>>> Parse error at line 1, column 8.  Encountered: static
>>>>
>>>> Total run time: 249 ms
>>>>
>>>> I tried all your scripts but none of them works...
>>>>
>>>> Poldi
>>>>
>>>>
>>>>
>>>>
>>>> andrea antonello wrote:
>>>>> Hi Poldi,
>>>>> are you using the last version available on the jgrass site?
>>>>>
>>>>> Also, could you please try to execute some simple scripts and tell me
>>>>> if they work?
>>>>>
>>>>> script 1:
>>>>>
>>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>>> # GISBASE= /opt/grass
>>>>>
>>>>> println "test"
>>>>>
>>>>>
>>>>> script 2:
>>>>>
>>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>>> # GISBASE= /opt/grass
>>>>>
>>>>> grass g.region --help
>>>>>
>>>>>
>>>>> script 3:
>>>>>
>>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>>> # GISBASE= /opt/grass
>>>>>
>>>>> jgrass {
>>>>> h.extractnetwork --help
>>>>> }
>>>>>
>>>>>
>>>>>
>>>>> Also could you please paste me the whole error message?
>>>>>
>>>>>
>>>>> Andrea
>>>>>
>>>>>
>>>>>
>>>>> On Wed, Jul 29, 2009 at 2:21 PM, Luitpold
>>>>> Hingerl<[hidden email]> wrote:
>>>>>> Hi Andrea,
>>>>>>
>>>>>> thank you very much for your fast answer.
>>>>>> Unfortunately the spaces didn't solve the problem, I still get the samer
>>>>>> error message...
>>>>>> Do you have any other idea?
>>>>>>
>>>>>> Greets,
>>>>>>
>>>>>> Poldi
>>>>>>
>>>>>>
>>>>>> andrea antonello wrote:
>>>>>>> Hi Poldi,
>>>>>>> some comments inline:
>>>>>>>
>>>>>>>> I have a problem running the console.
>>>>>>>> It's not possible to run any command, I always get the following error
>>>>>>>> message:
>>>>>>>> "Parse error at line 1, column 8.  Encountered: static"
>>>>>>> [...]
>>>>>>>> //Please uncomment and define the following options if needed:
>>>>>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>>>>>> # GISBASE= opt/grass
>>>>>>> this should not be the problem, but it should be /opt/grass
>>>>>>>
>>>>>>>> //# STARTDATE = 2009-08-03 06:00
>>>>>>>> //# ENDDATE = 2009-08-06 12:00
>>>>>>>> //# DELTAT= 30
>>>>>>>> //# RT= usually not needed
>>>>>>>> //# DEBUG= false
>>>>>>>> //# TRACE= false
>>>>>>>> //# NATIVEDEBUG= false
>>>>>>>> jgrass {h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>>>>>>> --threshold 100 --ograss-net net.100}
>>>>>>> Can you try it out with spaces from the brackets?
>>>>>>> i.e:
>>>>>>> jgrass {
>>>>>>>   h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>>>>>> --threshold 100 --ograss-net net.100
>>>>>>> }
>>>>>>>
>>>>>>>
>>>>>>> Let me know if it solves,
>>>>>>> Andrea
>>>>>>>
>>>>>>>
>>>>>>>> Any suggestions?
>>>>>>>> Thanks for your help!
>>>>>>>> Regards,
>>>>>>>>
>>>>>>>> Poldi
>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> JGrass-users mailing list
>>>>>>>> [hidden email]
>>>>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>>>>>
>>>>>>> _______________________________________________
>>>>>>> JGrass-users mailing list
>>>>>>> [hidden email]
>>>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>>> _______________________________________________
>>>>>> JGrass-users mailing list
>>>>>> [hidden email]
>>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>>>
>>>>> _______________________________________________
>>>>> JGrass-users mailing list
>>>>> [hidden email]
>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>> _______________________________________________
>>>> JGrass-users mailing list
>>>> [hidden email]
>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>
>>> _______________________________________________
>>> JGrass-users mailing list
>>> [hidden email]
>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>> _______________________________________________
>> JGrass-users mailing list
>> [hidden email]
>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>
> _______________________________________________
> JGrass-users mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users

_______________________________________________
JGrass-users mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
Reply | Threaded
Open this post in threaded view
|

Re: Console problems

Andrea Antonello
Hi Poldi,
good to hear that.

All the best,
Andrea




On Tue, Aug 4, 2009 at 6:06 PM, Luitpold
Hingerl<[hidden email]> wrote:

> Hello Andrea,
>
> thank you for your efforts!
> I have downloaded and installed the newest version and now it works
> properly.
>
> Best wishes,
>
> Poldi
>
>
> andrea antonello wrote:
>> Hi Poldi,
>> sorry for the delay. We have been quite busy.
>>
>> Anyways I just created a new build with many bug fixes and some
>> improvements. I don't think that your problems are bound to the
>> version. But I am quite sure something dirty is going on in your
>> install. Would you mind to download the latest version and try to
>> reinstall, possibly be cleaning up your workspace (i.e. removing it)?
>>
>> Ciao
>> Andrea
>>
>>
>>
>>
>> On Wed, Jul 29, 2009 at 4:31 PM, Luitpold
>> Hingerl<[hidden email]> wrote:
>>> Yes thats where I downloaded this version about 3 month ago...
>>> So this isn't the newest?
>>> I'm sorry if I'm asking stupid questions...
>>>
>>> Poldi
>>>
>>>
>>> andrea antonello wrote:
>>>>> I have the version 1.1.0. I think it is the newest isn't it?
>>>> 1.1.0?
>>>>
>>>> You installed through plugins into udig?
>>>> Didn't you take the last found here:
>>>> http://jgrass.wiki.software.bz.it/jgrass/Installation ?
>>>>
>>>>
>>>> Andrea
>>>>
>>>>
>>>>> This was theo whole error message look:
>>>>>
>>>>> JGrass 2 Console ML (Model Language) Compiler, Version 1.0.0.832, for i386
>>>>> Copyright (C)
>>>>>        HydroloGIS - www.hydrologis.com,
>>>>>        C.U.D.A.M. - http://www.unitn.it/dipartimenti/cudam
>>>>> -------------------------------- Compiling...
>>>>> ---------------------------------
>>>>> default.jgrass
>>>>> default.jgrass - 1 model/s compiled, total compilation time: 242 ms
>>>>>
>>>>> -------------------------------------------------------------------------------
>>>>> Beanshell, Version 2.0b4, Copyright (C) Pat Niemeyer
>>>>> ------------------------------ Running model...
>>>>> -------------------------------
>>>>> Parse error at line 1, column 8.  Encountered: static
>>>>>
>>>>> Total run time: 249 ms
>>>>>
>>>>> I tried all your scripts but none of them works...
>>>>>
>>>>> Poldi
>>>>>
>>>>>
>>>>>
>>>>>
>>>>> andrea antonello wrote:
>>>>>> Hi Poldi,
>>>>>> are you using the last version available on the jgrass site?
>>>>>>
>>>>>> Also, could you please try to execute some simple scripts and tell me
>>>>>> if they work?
>>>>>>
>>>>>> script 1:
>>>>>>
>>>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>>>> # GISBASE= /opt/grass
>>>>>>
>>>>>> println "test"
>>>>>>
>>>>>>
>>>>>> script 2:
>>>>>>
>>>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>>>> # GISBASE= /opt/grass
>>>>>>
>>>>>> grass g.region --help
>>>>>>
>>>>>>
>>>>>> script 3:
>>>>>>
>>>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>>>> # GISBASE= /opt/grass
>>>>>>
>>>>>> jgrass {
>>>>>> h.extractnetwork --help
>>>>>> }
>>>>>>
>>>>>>
>>>>>>
>>>>>> Also could you please paste me the whole error message?
>>>>>>
>>>>>>
>>>>>> Andrea
>>>>>>
>>>>>>
>>>>>>
>>>>>> On Wed, Jul 29, 2009 at 2:21 PM, Luitpold
>>>>>> Hingerl<[hidden email]> wrote:
>>>>>>> Hi Andrea,
>>>>>>>
>>>>>>> thank you very much for your fast answer.
>>>>>>> Unfortunately the spaces didn't solve the problem, I still get the samer
>>>>>>> error message...
>>>>>>> Do you have any other idea?
>>>>>>>
>>>>>>> Greets,
>>>>>>>
>>>>>>> Poldi
>>>>>>>
>>>>>>>
>>>>>>> andrea antonello wrote:
>>>>>>>> Hi Poldi,
>>>>>>>> some comments inline:
>>>>>>>>
>>>>>>>>> I have a problem running the console.
>>>>>>>>> It's not possible to run any command, I always get the following error
>>>>>>>>> message:
>>>>>>>>> "Parse error at line 1, column 8.  Encountered: static"
>>>>>>>> [...]
>>>>>>>>> //Please uncomment and define the following options if needed:
>>>>>>>>> # MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammout/ammout1
>>>>>>>>> # GISBASE= opt/grass
>>>>>>>> this should not be the problem, but it should be /opt/grass
>>>>>>>>
>>>>>>>>> //# STARTDATE = 2009-08-03 06:00
>>>>>>>>> //# ENDDATE = 2009-08-06 12:00
>>>>>>>>> //# DELTAT= 30
>>>>>>>>> //# RT= usually not needed
>>>>>>>>> //# DEBUG= false
>>>>>>>>> //# TRACE= false
>>>>>>>>> //# NATIVEDEBUG= false
>>>>>>>>> jgrass {h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>>>>>>>> --threshold 100 --ograss-net net.100}
>>>>>>>> Can you try it out with spaces from the brackets?
>>>>>>>> i.e:
>>>>>>>> jgrass {
>>>>>>>>   h.extractnetwork --mode 0 --igrass-flow markout --igrass-tca tca
>>>>>>>> --threshold 100 --ograss-net net.100
>>>>>>>> }
>>>>>>>>
>>>>>>>>
>>>>>>>> Let me know if it solves,
>>>>>>>> Andrea
>>>>>>>>
>>>>>>>>
>>>>>>>>> Any suggestions?
>>>>>>>>> Thanks for your help!
>>>>>>>>> Regards,
>>>>>>>>>
>>>>>>>>> Poldi
>>>>>>>>>
>>>>>>>>> _______________________________________________
>>>>>>>>> JGrass-users mailing list
>>>>>>>>> [hidden email]
>>>>>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>>>>>>
>>>>>>>> _______________________________________________
>>>>>>>> JGrass-users mailing list
>>>>>>>> [hidden email]
>>>>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>>>> _______________________________________________
>>>>>>> JGrass-users mailing list
>>>>>>> [hidden email]
>>>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>>>>
>>>>>> _______________________________________________
>>>>>> JGrass-users mailing list
>>>>>> [hidden email]
>>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>> _______________________________________________
>>>>> JGrass-users mailing list
>>>>> [hidden email]
>>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>>>
>>>> _______________________________________________
>>>> JGrass-users mailing list
>>>> [hidden email]
>>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>> _______________________________________________
>>> JGrass-users mailing list
>>> [hidden email]
>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>>>
>> _______________________________________________
>> JGrass-users mailing list
>> [hidden email]
>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>
> _______________________________________________
> JGrass-users mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
>
_______________________________________________
JGrass-users mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users