Error JAI en eclipse

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Error JAI en eclipse

Aibert [GARFEI Enginyeria]
Hola,

Estoy preparando entorno de programación con KOSMO 3.0 RC1 y me da un error.

Tengo instalado Java 64bits: jre8 y jdk1.8

Me da un error al ejecutar KOSMO desde eclipse. Me dice que: "La máquina virtual de Java que ejecuta la aplicación no tiene JAI instalado."

He instalado JAI (creo que es 32 bits): C:\Program Files (x86)\Sun Microsystems\Java Advanced Imaging 1.1.3\

El S.O. es Win8 64Bits.

La versión de eclipse es: Eclipse Standard/SDK. Version: Kepler Service Release 2. Build id: 20140224-0627

Espero que me podáis ayudar.

Gracias.

Saludos.

Reply | Threaded
Open this post in threaded view
|

Re: Error JAI en eclipse

Sergio Baños Calvo
Buenos días Aibert.

El problema es que si no recuerdo mal JAI es de 32 bits y el Java que has instalado es 1.8 y de 64 bits: Kosmo 3.0 RC1 está desarrollado en Java 1.6 y 32 bits. Lo más sencillo es usar el propio JRE que viene distribuido con Kosmo Desktop para el desarrollo.

Saludos,


El 21/04/2014 22:36, Aibert [GARFEI Enginyeria] escribió:
Hola,

Estoy preparando entorno de programación con KOSMO 3.0 RC1 y me da un error.

Tengo instalado Java 64bits: jre8 y jdk1.8

Me da un error al ejecutar KOSMO desde eclipse. Me dice que: "La máquina virtual de Java que ejecuta la aplicación no tiene JAI instalado."

He instalado JAI (creo que es 32 bits): C:\Program Files (x86)\Sun Microsystems\Java Advanced Imaging 1.1.3\

El S.O. es Win8 64Bits.

La versión de eclipse es: Eclipse Standard/SDK. Version: Kepler Service Release 2. Build id: 20140224-0627

Espero que me podáis ayudar.

Gracias.

Saludos.


--

Sergio Baños Calvo

Jefe de desarrollos / Development chief
Sistemas Abiertos de Información Geográfica,S.L. (SAIG S.L.)
Tlfno. móvil / Mobile phone: (+34) 685005960
Tlfno. fijo / Office phone: (+34) 954788876

E-mail: [hidden email]

Reply | Threaded
Open this post in threaded view
|

Re: Error JAI en eclipse

Aibert [GARFEI Enginyeria]
Hola Sergio,

Muchas gracias. ¿Como puedo hacer esto? ¿Que configuración tengo que cambiar en ECLIPSE?

Saludos.




2014-04-22 9:23 GMT+02:00 Sergio Baños Calvo <[hidden email]>:
Buenos días Aibert.

El problema es que si no recuerdo mal JAI es de 32 bits y el Java que has instalado es 1.8 y de 64 bits: Kosmo 3.0 RC1 está desarrollado en Java 1.6 y 32 bits. Lo más sencillo es usar el propio JRE que viene distribuido con Kosmo Desktop para el desarrollo.

Saludos,


El 21/04/2014 22:36, Aibert [GARFEI Enginyeria] escribió:
Hola,

Estoy preparando entorno de programación con KOSMO 3.0 RC1 y me da un error.

Tengo instalado Java 64bits: jre8 y jdk1.8

Me da un error al ejecutar KOSMO desde eclipse. Me dice que: "La máquina virtual de Java que ejecuta la aplicación no tiene JAI instalado."

He instalado JAI (creo que es 32 bits): C:\Program Files (x86)\Sun Microsystems\Java Advanced Imaging 1.1.3\

El S.O. es Win8 64Bits.

La versión de eclipse es: Eclipse Standard/SDK. Version: Kepler Service Release 2. Build id: 20140224-0627

Espero que me podáis ayudar.

Gracias.

Saludos.


--

Sergio Baños Calvo

Jefe de desarrollos / Development chief
Sistemas Abiertos de Información Geográfica,S.L. (SAIG S.L.)
Tlfno. móvil / Mobile phone: <a href="tel:%28%2B34%29%20685005960" value="+34685005960" target="_blank">(+34) 685005960
Tlfno. fijo / Office phone: <a href="tel:%28%2B34%29%20954788876" value="+34954788876" target="_blank">(+34) 954788876

E-mail: [hidden email]


Reply | Threaded
Open this post in threaded view
|

Re: Error JAI en eclipse

Sergio Baños Calvo-3
Buenas Aibert.

En la opción del menú de Eclipse Windows > Preferences, opción Java > Installed JREs, le das al botón "Add..." y añades el JRE que viene con Kosmo Desktop.

Luego en el proyecto le dices que use ese JRE y listo.

Saludos,


El 22/04/2014 16:08, Aibert [GARFEI Enginyeria] escribió:
Hola Sergio,

Muchas gracias. ¿Como puedo hacer esto? ¿Que configuración tengo que cambiar en ECLIPSE?

Saludos.




2014-04-22 9:23 GMT+02:00 Sergio Baños Calvo <[hidden email]>:
Buenos días Aibert.

El problema es que si no recuerdo mal JAI es de 32 bits y el Java que has instalado es 1.8 y de 64 bits: Kosmo 3.0 RC1 está desarrollado en Java 1.6 y 32 bits. Lo más sencillo es usar el propio JRE que viene distribuido con Kosmo Desktop para el desarrollo.

Saludos,


El 21/04/2014 22:36, Aibert [GARFEI Enginyeria] escribió:
Hola,

Estoy preparando entorno de programación con KOSMO 3.0 RC1 y me da un error.

Tengo instalado Java 64bits: jre8 y jdk1.8

Me da un error al ejecutar KOSMO desde eclipse. Me dice que: "La máquina virtual de Java que ejecuta la aplicación no tiene JAI instalado."

He instalado JAI (creo que es 32 bits): C:\Program Files (x86)\Sun Microsystems\Java Advanced Imaging 1.1.3\

El S.O. es Win8 64Bits.

La versión de eclipse es: Eclipse Standard/SDK. Version: Kepler Service Release 2. Build id: 20140224-0627

Espero que me podáis ayudar.

Gracias.

Saludos.


--

Sergio Baños Calvo

Jefe de desarrollos / Development chief
Sistemas Abiertos de Información Geográfica,S.L. (SAIG S.L.)
Tlfno. móvil / Mobile phone: <a moz-do-not-send="true" href="tel:%28%2B34%29%20685005960" value="+34685005960" target="_blank">(+34) 685005960
Tlfno. fijo / Office phone: <a moz-do-not-send="true" href="tel:%28%2B34%29%20954788876" value="+34954788876" target="_blank">(+34) 954788876

E-mail: [hidden email]




--

Sergio Baños Calvo

Jefe de desarrollos / Development chief
Sistemas Abiertos de Información Geográfica,S.L. (SAIG S.L.)
Tlfno. móvil / Mobile phone: (+34) 685005960
Tlfno. fijo / Office phone: (+34) 954788876

E-mail: [hidden email]