FW: [jira] (UDIG-1871) Error on uDig SDK Quickstart

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

FW: [jira] (UDIG-1871) Error on uDig SDK Quickstart

Nazareno Chan
Hi guys, I'm a new developer here at LISAsoft and I went through the tutorials and walkthroughs for uDig and stumbled upon the problem I posted on uDig's JIRA. If anyone has any info on its cause and/or resolution, kindly share, it might be of help to other starting newbies and myself.

Thanks,
Naz Chan


-----Original Message-----
From: Naz Chan (JIRA) [mailto:[hidden email]]
Sent: Friday, 13 January 2012 11:30 AM
To: Nazareno Chan
Subject: [jira] (UDIG-1871) Error on uDig SDK Quickstart

Naz Chan created UDIG-1871:
------------------------------

             Summary: Error on uDig SDK Quickstart
                 Key: UDIG-1871
                 URL: https://jira.codehaus.org/browse/UDIG-1871
             Project: uDIG
          Issue Type: Bug
          Components: installing and running udig
    Affects Versions: UDIG 1.3.1
         Environment: Win 7 - 64-bit
Eclipse 7.1.0
dropins-3.7.0
eclipse-3.7-delta-pack
jre1.6.0.win64
udig-1.3.1-sdk

            Reporter: Naz Chan
         Attachments: error.jpg

I went through the instructions in the SDK Quickstart tutorial step-by-step and used the components as specified above on the "Environment" field. It went through smoothly until the step to run the application, then I got the error (in the screenshot attached). You may notice in the Outline view (upper right of screenshot) that the two default dependencies have errors on them. I then tried to remove and re-add these dependencies (note that the udig_language-feature was not available and the udig-feature was of different version) and the app ran successfully.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



The contents of this email are confidential and may be subject to legal or professional privilege and copyright. No representation is made that this email is free of viruses or other defects. If you have received this communication in error, you may not copy or distribute any part of it or otherwise disclose its contents to anyone. Please advise the sender of your incorrect receipt of this correspondence.
_______________________________________________
udig-users mailing list
[hidden email]
http://lists.refractions.net/mailman/listinfo/udig-users
Reply | Threaded
Open this post in threaded view
|

UDIG-1871 Error on uDig SDK Quickstart

Jody Garnett-2
Welcome to uDig (and apparently LISAsoft - congrats!):

I did recently create the uDig 1.3.1 SDK with some help from Panagiotis. Indeed I was looking for a volunteer to test the SDK Quickstart before we announced anything. I get the impression Mr. Panagiotis tested with his own application and called it a day.

Usually what happens is that new functionality is added to uDig or Eclipse and we need to be careful to include the required plugins so the SDK Quickstart can be successful.

Thanks for the detailed bug report; I am going to have to think about that one a bit (as the plugin you imported has a net.refractions.udig.XXXX.jar of some sort; where I expected you to be able to see source code). Panagiotis did a bunch of hard work on changing how the source code is packaged; so I expect the SDKQuickstart will need to follow suite.



-- 
Jody Garnett

On Friday, 13 January 2012 at 10:36 AM, Nazareno Chan wrote:

Hi guys, I'm a new developer here at LISAsoft and I went through the tutorials and walkthroughs for uDig and stumbled upon the problem I posted on uDig's JIRA. If anyone has any info on its cause and/or resolution, kindly share, it might be of help to other starting newbies and myself.

Thanks,
Naz Chan


-----Original Message-----
From: Naz Chan (JIRA) [[hidden email]]
Sent: Friday, 13 January 2012 11:30 AM
To: Nazareno Chan
Subject: [jira] (UDIG-1871) Error on uDig SDK Quickstart

Naz Chan created UDIG-1871:
------------------------------

Summary: Error on uDig SDK Quickstart
Key: UDIG-1871
Project: uDIG
Issue Type: Bug
Components: installing and running udig
Affects Versions: UDIG 1.3.1
Environment: Win 7 - 64-bit
Eclipse 7.1.0
dropins-3.7.0
eclipse-3.7-delta-pack
jre1.6.0.win64
udig-1.3.1-sdk

Reporter: Naz Chan
Attachments: error.jpg

I went through the instructions in the SDK Quickstart tutorial step-by-step and used the components as specified above on the "Environment" field. It went through smoothly until the step to run the application, then I got the error (in the screenshot attached). You may notice in the Outline view (upper right of screenshot) that the two default dependencies have errors on them. I then tried to remove and re-add these dependencies (note that the udig_language-feature was not available and the udig-feature was of different version) and the app ran successfully.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://jira.codehaus.org/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira



The contents of this email are confidential and may be subject to legal or professional privilege and copyright. No representation is made that this email is free of viruses or other defects. If you have received this communication in error, you may not copy or distribute any part of it or otherwise disclose its contents to anyone. Please advise the sender of your incorrect receipt of this correspondence.
_______________________________________________
udig-users mailing list


_______________________________________________
udig-users mailing list
[hidden email]
http://lists.refractions.net/mailman/listinfo/udig-users