INSTALACIÓN KOSMO EN ECLIPSE

classic Classic list List threaded Threaded
13 messages Options
Reply | Threaded
Open this post in threaded view
|

INSTALACIÓN KOSMO EN ECLIPSE

Susana Iraiis Delgado Rodriguez
A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.

_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo
Reply | Threaded
Open this post in threaded view
|

Re: INSTALACIÓN KOSMO EN ECLIPSE

Susana Iraiis Delgado Rodriguez
Hola:
 
Ya consegui instalar el JAI, el problema era la serie de permisos en la red y el equipo de cómputo; estoy siguiendo al pie de la letra el manual de instalación de KOSMO para Eclipse, pero la versión del manual es obsoleta a mi versión de java (1.6), el problema es que al momento de crear el proyecto con el nombre saig-core, una vez que se agregaron al workspace las carpetas de Kosmo, no puedo marcar que el proyecto viene de esa fuente y cuando lo logre me manda un error en la clase com.vividsolutions.jump.workbench, alguien tiene idea de que estoy haciendo mal?

El 24 de agosto de 2010 14:13, Juan Jose Del Toro <[hidden email]> escribió:
Susana;

Cehca este correo
http://www.mail-archive.com/kosmo@.../msg01375.html

El 24 de agosto de 2010 09:54, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:

Buenos días Ingeniero:
 
Le reenvio copia del mensaje que mendé a la lsita de colaboradores kosmo; además para comentarle sobre la instalación de GeoTools, ya se descargó la versión de NetBeans, pero al tratar de instalarla me manda un mesaje donde se indica que el arcuivo esta dañado; trataré de seguir con las instalaciones o quiere que prosiga con lo de CSS; sin màs por el momento procederé a enviar el correo en inglés a Kosmo.
 
Nos vemos luego.

---------- Mensaje reenviado ----------
De: Susana Iraiis Delgado Rodriguez <[hidden email]>
Fecha: 24 de agosto de 2010 09:51
Asunto: INSTALACIÓN KOSMO EN ECLIPSE
Para: [hidden email]



A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.




--
¡Saludos! / Greetings!
Juan José Del Toro M.
[hidden email]
Guadalajara, Jalisco MEXICO



_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo
Reply | Threaded
Open this post in threaded view
|

Re: INSTALACIÓN KOSMO EN ECLIPSE

Sergio Baños Calvo-2
Buenos días Susana.

Si puede indicarnos el error que le aparece en Eclipse (mediante una captura de pantalla por ejemplo) podremos ayudarle.

En principio la guía de usuario (salvo la versión exacta de Java a utilizar, que cuando se redactó era una máquina virtual 1.5) es válida para la última distribución de fuentes existentes.

Un cordial saludo,

El 24/08/2010 23:28, Susana Iraiis Delgado Rodriguez escribió:
Hola:
 
Ya consegui instalar el JAI, el problema era la serie de permisos en la red y el equipo de cómputo; estoy siguiendo al pie de la letra el manual de instalación de KOSMO para Eclipse, pero la versión del manual es obsoleta a mi versión de java (1.6), el problema es que al momento de crear el proyecto con el nombre saig-core, una vez que se agregaron al workspace las carpetas de Kosmo, no puedo marcar que el proyecto viene de esa fuente y cuando lo logre me manda un error en la clase com.vividsolutions.jump.workbench, alguien tiene idea de que estoy haciendo mal?

El 24 de agosto de 2010 14:13, Juan Jose Del Toro <[hidden email]> escribió:
Susana;

Cehca este correo
http://www.mail-archive.com/kosmo@.../msg01375.html

El 24 de agosto de 2010 09:54, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:

Buenos días Ingeniero:
 
Le reenvio copia del mensaje que mendé a la lsita de colaboradores kosmo; además para comentarle sobre la instalación de GeoTools, ya se descargó la versión de NetBeans, pero al tratar de instalarla me manda un mesaje donde se indica que el arcuivo esta dañado; trataré de seguir con las instalaciones o quiere que prosiga con lo de CSS; sin màs por el momento procederé a enviar el correo en inglés a Kosmo.
 
Nos vemos luego.

---------- Mensaje reenviado ----------
De: Susana Iraiis Delgado Rodriguez <[hidden email]>
Fecha: 24 de agosto de 2010 09:51
Asunto: INSTALACIÓN KOSMO EN ECLIPSE
Para: [hidden email]



A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.




--
¡Saludos! / Greetings!
Juan José Del Toro M.
[hidden email]
Guadalajara, Jalisco MEXICO


_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo
Reply | Threaded
Open this post in threaded view
|

Re: INSTALACIÓN KOSMO EN ECLIPSE

Susana Iraiis Delgado Rodriguez
Hola Sergio:
 
Gracias por responder a mi correo; he seguido las instrucciones del manual para cargar Kosmo desde Eclipse; el error radica en las instrucciones de la página 25 del manual; una vez que cargo el proyecto saig-core, se adjuntan los archivos por default, pero al terminar de construir el workspace aparecen varios errores,  los adjunto en este correo.
 
Espero me pueda ayudar.
 
Gracias!!!
El 25 de agosto de 2010 01:23, Sergio Baños Calvo <[hidden email]> escribió:
Buenos días Susana.

Si puede indicarnos el error que le aparece en Eclipse (mediante una captura de pantalla por ejemplo) podremos ayudarle.

En principio la guía de usuario (salvo la versión exacta de Java a utilizar, que cuando se redactó era una máquina virtual 1.5) es válida para la última distribución de fuentes existentes.

Un cordial saludo,

El 24/08/2010 23:28, Susana Iraiis Delgado Rodriguez escribió:
Hola:
 
Ya consegui instalar el JAI, el problema era la serie de permisos en la red y el equipo de cómputo; estoy siguiendo al pie de la letra el manual de instalación de KOSMO para Eclipse, pero la versión del manual es obsoleta a mi versión de java (1.6), el problema es que al momento de crear el proyecto con el nombre saig-core, una vez que se agregaron al workspace las carpetas de Kosmo, no puedo marcar que el proyecto viene de esa fuente y cuando lo logre me manda un error en la clase com.vividsolutions.jump.workbench, alguien tiene idea de que estoy haciendo mal?

El 24 de agosto de 2010 14:13, Juan Jose Del Toro <[hidden email]> escribió:
Susana;

Cehca este correo
http://www.mail-archive.com/kosmo@.../msg01375.html

El 24 de agosto de 2010 09:54, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:

Buenos días Ingeniero:
 
Le reenvio copia del mensaje que mendé a la lsita de colaboradores kosmo; además para comentarle sobre la instalación de GeoTools, ya se descargó la versión de NetBeans, pero al tratar de instalarla me manda un mesaje donde se indica que el arcuivo esta dañado; trataré de seguir con las instalaciones o quiere que prosiga con lo de CSS; sin màs por el momento procederé a enviar el correo en inglés a Kosmo.
 
Nos vemos luego.

---------- Mensaje reenviado ----------
De: Susana Iraiis Delgado Rodriguez <[hidden email]>
Fecha: 24 de agosto de 2010 09:51
Asunto: INSTALACIÓN KOSMO EN ECLIPSE
Para: [hidden email]



A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.




--
¡Saludos! / Greetings!
Juan José Del Toro M.
[hidden email]
Guadalajara, Jalisco MEXICO


_______________________________________________ Kosmo mailing list [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo



_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo

saig-core error.JPG (124K) Download Attachment
saig-core error2.JPG (226K) Download Attachment
saig-core error3.JPG (220K) Download Attachment
saig-core error4.JPG (172K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: INSTALACIÓN KOSMO EN ECLIPSE

Susana Iraiis Delgado Rodriguez
Hola Sergio:
 
Ya resolví los problemas anteriores, se solucionó mediante la instalación del jar JAI; además de la desinstalación del jdk de java versión 1.6 update 21 por el java versión 1.6 update 3. Ahora el problema que tengo y que se muestra es el siguiente:
 
Description Resource Path Location Type
The project was not built since its build path is incomplete. Cannot find the class file for javax.media.jai.util.Range. Fix the build path then try building this project saig-core  Unknown Java Problem.
 
Description Resource Path Location Type
The type javax.media.jai.util.Range cannot be resolved. It is indirectly referenced from required .class files SelectionRenderer.java /saig-core/src/org/saig/core/renderer2 line 163 Java Problem


El 25 de agosto de 2010 11:50, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:
Hola Sergio:
 
Gracias por responder a mi correo; he seguido las instrucciones del manual para cargar Kosmo desde Eclipse; el error radica en las instrucciones de la página 25 del manual; una vez que cargo el proyecto saig-core, se adjuntan los archivos por default, pero al terminar de construir el workspace aparecen varios errores,  los adjunto en este correo.
 
Espero me pueda ayudar.
 
Gracias!!!
El 25 de agosto de 2010 01:23, Sergio Baños Calvo <[hidden email]> escribió:

Buenos días Susana.

Si puede indicarnos el error que le aparece en Eclipse (mediante una captura de pantalla por ejemplo) podremos ayudarle.

En principio la guía de usuario (salvo la versión exacta de Java a utilizar, que cuando se redactó era una máquina virtual 1.5) es válida para la última distribución de fuentes existentes.

Un cordial saludo,

El 24/08/2010 23:28, Susana Iraiis Delgado Rodriguez escribió:
Hola:
 
Ya consegui instalar el JAI, el problema era la serie de permisos en la red y el equipo de cómputo; estoy siguiendo al pie de la letra el manual de instalación de KOSMO para Eclipse, pero la versión del manual es obsoleta a mi versión de java (1.6), el problema es que al momento de crear el proyecto con el nombre saig-core, una vez que se agregaron al workspace las carpetas de Kosmo, no puedo marcar que el proyecto viene de esa fuente y cuando lo logre me manda un error en la clase com.vividsolutions.jump.workbench, alguien tiene idea de que estoy haciendo mal?

El 24 de agosto de 2010 14:13, Juan Jose Del Toro <[hidden email]> escribió:
Susana;

Cehca este correo
http://www.mail-archive.com/kosmo@.../msg01375.html

El 24 de agosto de 2010 09:54, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:

Buenos días Ingeniero:
 
Le reenvio copia del mensaje que mendé a la lsita de colaboradores kosmo; además para comentarle sobre la instalación de GeoTools, ya se descargó la versión de NetBeans, pero al tratar de instalarla me manda un mesaje donde se indica que el arcuivo esta dañado; trataré de seguir con las instalaciones o quiere que prosiga con lo de CSS; sin màs por el momento procederé a enviar el correo en inglés a Kosmo.
 
Nos vemos luego.

---------- Mensaje reenviado ----------
De: Susana Iraiis Delgado Rodriguez <[hidden email]>
Fecha: 24 de agosto de 2010 09:51
Asunto: INSTALACIÓN KOSMO EN ECLIPSE
Para: [hidden email]



A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.




--
¡Saludos! / Greetings!
Juan José Del Toro M.
[hidden email]
Guadalajara, Jalisco MEXICO


_______________________________________________ Kosmo mailing list [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo




_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo

jai-error.JPG (146K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: INSTALACIÓN KOSMO EN ECLIPSE

Sergio Baños Calvo
Buenas tardes Susana.

Le comento una serie de pasos que le recomiendo para configurar correctamente su entorno de desarrollo:

1) Instalar la última versión del JDK de Java: http://www.oracle.com/technetwork/java/javase/downloads/jdk6-jsp-136632.html

Kosmo Desktop 2.0 RC1 funciona con JRE 1.6_03, pero puede desarrollar perfectamente con la última versión de Java disponible (nosotros estamos trabajando ahora mismo con el JDK 1.6_20).

2) Instalar la última versión disponible de JAI (la versión 1.3 para su sistema operativo) de la página https://jai.dev.java.net/binary-builds.html

- Windows: http://download.java.net/media/jai/builds/release/1_1_3/jai-1_1_3-lib-windows-i586-jdk.exe
- Linux: jai-1_1_3-lib-linux-i586-jdk.bin


3) Configurar Eclipse para que use dicho JDK para compilar

- Windows > Preferences > Java > Installed JREs y pulse el botón "Add" para incluir este nuevo JDK. Seleccione el directorio correspondiente a su instalación del JDK.
- Una vez añadido, en el listado de JRE system libraries de la misma pantalla debe incluir dos entradas correspondientes a jai_codec.jar y jai_core.jar (además de otro conjunto de entradas).

Si después de realizar estos pasos sigue quedando algún error comuníquemelo para poder ayudarle.

Saludos,


El 25/08/2010 21:38, Susana Iraiis Delgado Rodriguez escribió:
Hola Sergio:
 
Ya resolví los problemas anteriores, se solucionó mediante la instalación del jar JAI; además de la desinstalación del jdk de java versión 1.6 update 21 por el java versión 1.6 update 3. Ahora el problema que tengo y que se muestra es el siguiente:
 
Description Resource Path Location Type
The project was not built since its build path is incomplete. Cannot find the class file for javax.media.jai.util.Range. Fix the build path then try building this project saig-core  Unknown Java Problem.
 
Description Resource Path Location Type
The type javax.media.jai.util.Range cannot be resolved. It is indirectly referenced from required .class files SelectionRenderer.java /saig-core/src/org/saig/core/renderer2 line 163 Java Problem


El 25 de agosto de 2010 11:50, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:
Hola Sergio:
 
Gracias por responder a mi correo; he seguido las instrucciones del manual para cargar Kosmo desde Eclipse; el error radica en las instrucciones de la página 25 del manual; una vez que cargo el proyecto saig-core, se adjuntan los archivos por default, pero al terminar de construir el workspace aparecen varios errores,  los adjunto en este correo.
 
Espero me pueda ayudar.
 
Gracias!!!
El 25 de agosto de 2010 01:23, Sergio Baños Calvo <[hidden email]> escribió:

Buenos días Susana.

Si puede indicarnos el error que le aparece en Eclipse (mediante una captura de pantalla por ejemplo) podremos ayudarle.

En principio la guía de usuario (salvo la versión exacta de Java a utilizar, que cuando se redactó era una máquina virtual 1.5) es válida para la última distribución de fuentes existentes.

Un cordial saludo,

El 24/08/2010 23:28, Susana Iraiis Delgado Rodriguez escribió:
Hola:
 
Ya consegui instalar el JAI, el problema era la serie de permisos en la red y el equipo de cómputo; estoy siguiendo al pie de la letra el manual de instalación de KOSMO para Eclipse, pero la versión del manual es obsoleta a mi versión de java (1.6), el problema es que al momento de crear el proyecto con el nombre saig-core, una vez que se agregaron al workspace las carpetas de Kosmo, no puedo marcar que el proyecto viene de esa fuente y cuando lo logre me manda un error en la clase com.vividsolutions.jump.workbench, alguien tiene idea de que estoy haciendo mal?

El 24 de agosto de 2010 14:13, Juan Jose Del Toro <[hidden email]> escribió:
Susana;

Cehca este correo
http://www.mail-archive.com/kosmo@.../msg01375.html

El 24 de agosto de 2010 09:54, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:

Buenos días Ingeniero:
 
Le reenvio copia del mensaje que mendé a la lsita de colaboradores kosmo; además para comentarle sobre la instalación de GeoTools, ya se descargó la versión de NetBeans, pero al tratar de instalarla me manda un mesaje donde se indica que el arcuivo esta dañado; trataré de seguir con las instalaciones o quiere que prosiga con lo de CSS; sin màs por el momento procederé a enviar el correo en inglés a Kosmo.
 
Nos vemos luego.

---------- Mensaje reenviado ----------
De: Susana Iraiis Delgado Rodriguez <[hidden email]>
Fecha: 24 de agosto de 2010 09:51
Asunto: INSTALACIÓN KOSMO EN ECLIPSE
Para: [hidden email]



A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.




--
¡Saludos! / Greetings!
Juan José Del Toro M.
[hidden email]
Guadalajara, Jalisco MEXICO


_______________________________________________ Kosmo mailing list [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo



_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo

--

Sergio Baños Calvo

Jefe de desarrollos
Sistemas Abiertos de Información Geográfica, S.L. (SAIG S.L.)
Tlfno. móvil: 685005960
Tlfno. fijo: (+34) 954788876

E-mail: [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo
Reply | Threaded
Open this post in threaded view
|

Re: INSTALACIÓN KOSMO EN ECLIPSE

Sergio Baños Calvo-2
Buenas de nuevo.

Corrijo un par de errores de mi último correo:

2) Instalar la última versión disponible de JAI (la versión 1.1.3 para su sistema operativo) de la página https://jai.dev.java.net/binary-builds.html

- Windows: http://download.java.net/media/jai/builds/release/1_1_3/jai-1_1_3-lib-windows-i586-jdk.exe
- Linux: http://download.java.net/media/jai/builds/release/1_1_3/jai-1_1_3-lib-linux-i586-jdk.bin

Saludos,


El 26/08/2010 16:17, Sergio Baños Calvo escribió:
Buenas tardes Susana.

Le comento una serie de pasos que le recomiendo para configurar correctamente su entorno de desarrollo:

1) Instalar la última versión del JDK de Java: http://www.oracle.com/technetwork/java/javase/downloads/jdk6-jsp-136632.html

Kosmo Desktop 2.0 RC1 funciona con JRE 1.6_03, pero puede desarrollar perfectamente con la última versión de Java disponible (nosotros estamos trabajando ahora mismo con el JDK 1.6_20).

2) Instalar la última versión disponible de JAI (la versión 1.3 para su sistema operativo) de la página https://jai.dev.java.net/binary-builds.html

- Windows: http://download.java.net/media/jai/builds/release/1_1_3/jai-1_1_3-lib-windows-i586-jdk.exe
- Linux: jai-1_1_3-lib-linux-i586-jdk.bin


3) Configurar Eclipse para que use dicho JDK para compilar

- Windows > Preferences > Java > Installed JREs y pulse el botón "Add" para incluir este nuevo JDK. Seleccione el directorio correspondiente a su instalación del JDK.
- Una vez añadido, en el listado de JRE system libraries de la misma pantalla debe incluir dos entradas correspondientes a jai_codec.jar y jai_core.jar (además de otro conjunto de entradas).

Si después de realizar estos pasos sigue quedando algún error comuníquemelo para poder ayudarle.

Saludos,


El 25/08/2010 21:38, Susana Iraiis Delgado Rodriguez escribió:
Hola Sergio:
 
Ya resolví los problemas anteriores, se solucionó mediante la instalación del jar JAI; además de la desinstalación del jdk de java versión 1.6 update 21 por el java versión 1.6 update 3. Ahora el problema que tengo y que se muestra es el siguiente:
 
Description Resource Path Location Type
The project was not built since its build path is incomplete. Cannot find the class file for javax.media.jai.util.Range. Fix the build path then try building this project saig-core  Unknown Java Problem.
 
Description Resource Path Location Type
The type javax.media.jai.util.Range cannot be resolved. It is indirectly referenced from required .class files SelectionRenderer.java /saig-core/src/org/saig/core/renderer2 line 163 Java Problem


El 25 de agosto de 2010 11:50, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:
Hola Sergio:
 
Gracias por responder a mi correo; he seguido las instrucciones del manual para cargar Kosmo desde Eclipse; el error radica en las instrucciones de la página 25 del manual; una vez que cargo el proyecto saig-core, se adjuntan los archivos por default, pero al terminar de construir el workspace aparecen varios errores,  los adjunto en este correo.
 
Espero me pueda ayudar.
 
Gracias!!!
El 25 de agosto de 2010 01:23, Sergio Baños Calvo <[hidden email]> escribió:

Buenos días Susana.

Si puede indicarnos el error que le aparece en Eclipse (mediante una captura de pantalla por ejemplo) podremos ayudarle.

En principio la guía de usuario (salvo la versión exacta de Java a utilizar, que cuando se redactó era una máquina virtual 1.5) es válida para la última distribución de fuentes existentes.

Un cordial saludo,

El 24/08/2010 23:28, Susana Iraiis Delgado Rodriguez escribió:
Hola:
 
Ya consegui instalar el JAI, el problema era la serie de permisos en la red y el equipo de cómputo; estoy siguiendo al pie de la letra el manual de instalación de KOSMO para Eclipse, pero la versión del manual es obsoleta a mi versión de java (1.6), el problema es que al momento de crear el proyecto con el nombre saig-core, una vez que se agregaron al workspace las carpetas de Kosmo, no puedo marcar que el proyecto viene de esa fuente y cuando lo logre me manda un error en la clase com.vividsolutions.jump.workbench, alguien tiene idea de que estoy haciendo mal?

El 24 de agosto de 2010 14:13, Juan Jose Del Toro <[hidden email]> escribió:
Susana;

Cehca este correo
http://www.mail-archive.com/kosmo@.../msg01375.html

El 24 de agosto de 2010 09:54, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:

Buenos días Ingeniero:
 
Le reenvio copia del mensaje que mendé a la lsita de colaboradores kosmo; además para comentarle sobre la instalación de GeoTools, ya se descargó la versión de NetBeans, pero al tratar de instalarla me manda un mesaje donde se indica que el arcuivo esta dañado; trataré de seguir con las instalaciones o quiere que prosiga con lo de CSS; sin màs por el momento procederé a enviar el correo en inglés a Kosmo.
 
Nos vemos luego.

---------- Mensaje reenviado ----------
De: Susana Iraiis Delgado Rodriguez <[hidden email]>
Fecha: 24 de agosto de 2010 09:51
Asunto: INSTALACIÓN KOSMO EN ECLIPSE
Para: [hidden email]



A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.




--
¡Saludos! / Greetings!
Juan José Del Toro M.
[hidden email]
Guadalajara, Jalisco MEXICO


_______________________________________________ Kosmo mailing list [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo



_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo

--

Sergio Baños Calvo

Jefe de desarrollos
Sistemas Abiertos de Información Geográfica, S.L. (SAIG S.L.)
Tlfno. móvil: 685005960
Tlfno. fijo: (+34) 954788876

E-mail: [hidden email]

_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo
Reply | Threaded
Open this post in threaded view
|

Re: INSTALACIÓN KOSMO EN ECLIPSE

Susana Iraiis Delgado Rodriguez
In reply to this post by Sergio Baños Calvo
Buenas tardes Sergio:
 
En primer lugar muchas gracias por su ayuda, me han sido útiles sus indicaciones. Ya realizé los pasos que me indicó al pie de la letra`:
  • Instalé la versión java 1.6_20 con el jai que me indico. Al configuar en el window>preferences>java>installed JRE se me agregaron por defaults los jars que me había indicado, todo salido bien y configure para el proyecto el JDK que ínstalé. 
  • Al crear el proyecto de acuerdo al manual no tengo la opción de <create project from existing source, pero si carga los archivos.
Mis dudas son:
  • Una vez que agregó las librerias no tengo el jar CATMEdit.jar que se indica en el manual
  • Ya que se termina de crear el workspace tengo un error en el paquete  org.saig.jump.widgets.util, clase CheckBoxJListSelectionPanel, en la pantalla de errores aparece
The method sort(List<T>, Comparator<? super T>) in the type Collections is not applicable for the arguments (List, Comparator<capture#3-of ?>) CheckBoxJListSelectionPanel.java /saig-core/src/org/saig/jump/widgets/util line 285 Java Problem
 
De cualquier forma adjunto imagen del error, gracias por su atención y paciencia
 
El 26 de agosto de 2010 09:17, Sergio Baños Calvo <[hidden email]> escribió:
Buenas tardes Susana.

Le comento una serie de pasos que le recomiendo para configurar correctamente su entorno de desarrollo:

1) Instalar la última versión del JDK de Java: http://www.oracle.com/technetwork/java/javase/downloads/jdk6-jsp-136632.html

Kosmo Desktop 2.0 RC1 funciona con JRE 1.6_03, pero puede desarrollar perfectamente con la última versión de Java disponible (nosotros estamos trabajando ahora mismo con el JDK 1.6_20).

2) Instalar la última versión disponible de JAI (la versión 1.3 para su sistema operativo) de la página https://jai.dev.java.net/binary-builds.html

- Windows: http://download.java.net/media/jai/builds/release/1_1_3/jai-1_1_3-lib-windows-i586-jdk.exe
- Linux: jai-1_1_3-lib-linux-i586-jdk.bin


3) Configurar Eclipse para que use dicho JDK para compilar

- Windows > Preferences > Java > Installed JREs y pulse el botón "Add" para incluir este nuevo JDK. Seleccione el directorio correspondiente a su instalación del JDK.
- Una vez añadido, en el listado de JRE system libraries de la misma pantalla debe incluir dos entradas correspondientes a jai_codec.jar y jai_core.jar (además de otro conjunto de entradas).

Si después de realizar estos pasos sigue quedando algún error comuníquemelo para poder ayudarle.

Saludos,


El 25/08/2010 21:38, Susana Iraiis Delgado Rodriguez escribió:
Hola Sergio:
 
Ya resolví los problemas anteriores, se solucionó mediante la instalación del jar JAI; además de la desinstalación del jdk de java versión 1.6 update 21 por el java versión 1.6 update 3. Ahora el problema que tengo y que se muestra es el siguiente:
 
Description Resource Path Location Type
The project was not built since its build path is incomplete. Cannot find the class file for javax.media.jai.util.Range. Fix the build path then try building this project saig-core  Unknown Java Problem.
 
Description Resource Path Location Type
The type javax.media.jai.util.Range cannot be resolved. It is indirectly referenced from required .class files SelectionRenderer.java /saig-core/src/org/saig/core/renderer2 line 163 Java Problem


El 25 de agosto de 2010 11:50, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:
Hola Sergio:
 
Gracias por responder a mi correo; he seguido las instrucciones del manual para cargar Kosmo desde Eclipse; el error radica en las instrucciones de la página 25 del manual; una vez que cargo el proyecto saig-core, se adjuntan los archivos por default, pero al terminar de construir el workspace aparecen varios errores,  los adjunto en este correo.
 
Espero me pueda ayudar.
 
Gracias!!!
El 25 de agosto de 2010 01:23, Sergio Baños Calvo <[hidden email]> escribió:

Buenos días Susana.

Si puede indicarnos el error que le aparece en Eclipse (mediante una captura de pantalla por ejemplo) podremos ayudarle.

En principio la guía de usuario (salvo la versión exacta de Java a utilizar, que cuando se redactó era una máquina virtual 1.5) es válida para la última distribución de fuentes existentes.

Un cordial saludo,

El 24/08/2010 23:28, Susana Iraiis Delgado Rodriguez escribió:
Hola:
 
Ya consegui instalar el JAI, el problema era la serie de permisos en la red y el equipo de cómputo; estoy siguiendo al pie de la letra el manual de instalación de KOSMO para Eclipse, pero la versión del manual es obsoleta a mi versión de java (1.6), el problema es que al momento de crear el proyecto con el nombre saig-core, una vez que se agregaron al workspace las carpetas de Kosmo, no puedo marcar que el proyecto viene de esa fuente y cuando lo logre me manda un error en la clase com.vividsolutions.jump.workbench, alguien tiene idea de que estoy haciendo mal?

El 24 de agosto de 2010 14:13, Juan Jose Del Toro <[hidden email]> escribió:
Susana;

Cehca este correo
http://www.mail-archive.com/kosmo@.../msg01375.html

El 24 de agosto de 2010 09:54, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:

Buenos días Ingeniero:
 
Le reenvio copia del mensaje que mendé a la lsita de colaboradores kosmo; además para comentarle sobre la instalación de GeoTools, ya se descargó la versión de NetBeans, pero al tratar de instalarla me manda un mesaje donde se indica que el arcuivo esta dañado; trataré de seguir con las instalaciones o quiere que prosiga con lo de CSS; sin màs por el momento procederé a enviar el correo en inglés a Kosmo.
 
Nos vemos luego.

---------- Mensaje reenviado ----------
De: Susana Iraiis Delgado Rodriguez <[hidden email]>
Fecha: 24 de agosto de 2010 09:51
Asunto: INSTALACIÓN KOSMO EN ECLIPSE
Para: [hidden email]



A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.




--
¡Saludos! / Greetings!
Juan José Del Toro M.
[hidden email]
Guadalajara, Jalisco MEXICO


_______________________________________________ Kosmo mailing list [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo



_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo

--

Sergio Baños Calvo

Jefe de desarrollos
Sistemas Abiertos de Información Geográfica, S.L. (SAIG S.L.)
Tlfno. móvil: 685005960
Tlfno. fijo: (+34) 954788876

E-mail: [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo



_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo

saig-core.JPG (164K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: INSTALACIÓN KOSMO EN ECLIPSE

Sergio Baños Calvo-2
Buenas de nuevo Susana.

Le comento las dudas planteadas:

1) Una vez que agregó las librerias no tengo el jar CATMEdit.jar que se indica en el manual

La sección correspondiente al jar CATMEdit.jar está obsoleta, dicho jar ya no está incluido en la distribución y no es necesario ordenarlo de la forma indicada en el manual (si era un paso obligatorio en versiones anteriores).


2) Ya que se termina de crear el workspace tengo un error en el paquete  org.saig.jump.widgets.util, clase CheckBoxJListSelectionPanel, en la pantalla de errores aparece

Compruebe que las opciones correspondientes a :

- Windows > Preferences > Java > Compiler > Error/Warnings, sección Generics, estén todos a Warning.

Si está configurado de esta forma y persiste el error, mañana por la mañana compruebo otra posible solución al problema.

Saludos,

El 26/08/2010 22:43, Susana Iraiis Delgado Rodriguez escribió:
Buenas tardes Sergio:
 
En primer lugar muchas gracias por su ayuda, me han sido útiles sus indicaciones. Ya realizé los pasos que me indicó al pie de la letra`:
  • Instalé la versión java 1.6_20 con el jai que me indico. Al configuar en el window>preferences>java>installed JRE se me agregaron por defaults los jars que me había indicado, todo salido bien y configure para el proyecto el JDK que ínstalé. 
  • Al crear el proyecto de acuerdo al manual no tengo la opción de <create project from existing source, pero si carga los archivos.
Mis dudas son:
  • Una vez que agregó las librerias no tengo el jar CATMEdit.jar que se indica en el manual
  • Ya que se termina de crear el workspace tengo un error en el paquete  org.saig.jump.widgets.util, clase CheckBoxJListSelectionPanel, en la pantalla de errores aparece
The method sort(List<T>, Comparator<? super T>) in the type Collections is not applicable for the arguments (List, Comparator<capture#3-of ?>) CheckBoxJListSelectionPanel.java /saig-core/src/org/saig/jump/widgets/util line 285 Java Problem
 
De cualquier forma adjunto imagen del error, gracias por su atención y paciencia
 
El 26 de agosto de 2010 09:17, Sergio Baños Calvo <[hidden email]> escribió:
Buenas tardes Susana.

Le comento una serie de pasos que le recomiendo para configurar correctamente su entorno de desarrollo:

1) Instalar la última versión del JDK de Java: http://www.oracle.com/technetwork/java/javase/downloads/jdk6-jsp-136632.html

Kosmo Desktop 2.0 RC1 funciona con JRE 1.6_03, pero puede desarrollar perfectamente con la última versión de Java disponible (nosotros estamos trabajando ahora mismo con el JDK 1.6_20).

2) Instalar la última versión disponible de JAI (la versión 1.3 para su sistema operativo) de la página https://jai.dev.java.net/binary-builds.html

- Windows: http://download.java.net/media/jai/builds/release/1_1_3/jai-1_1_3-lib-windows-i586-jdk.exe
- Linux: jai-1_1_3-lib-linux-i586-jdk.bin


3) Configurar Eclipse para que use dicho JDK para compilar

- Windows > Preferences > Java > Installed JREs y pulse el botón "Add" para incluir este nuevo JDK. Seleccione el directorio correspondiente a su instalación del JDK.
- Una vez añadido, en el listado de JRE system libraries de la misma pantalla debe incluir dos entradas correspondientes a jai_codec.jar y jai_core.jar (además de otro conjunto de entradas).

Si después de realizar estos pasos sigue quedando algún error comuníquemelo para poder ayudarle.

Saludos,


El 25/08/2010 21:38, Susana Iraiis Delgado Rodriguez escribió:
Hola Sergio:
 
Ya resolví los problemas anteriores, se solucionó mediante la instalación del jar JAI; además de la desinstalación del jdk de java versión 1.6 update 21 por el java versión 1.6 update 3. Ahora el problema que tengo y que se muestra es el siguiente:
 
Description Resource Path Location Type
The project was not built since its build path is incomplete. Cannot find the class file for javax.media.jai.util.Range. Fix the build path then try building this project saig-core  Unknown Java Problem.
 
Description Resource Path Location Type
The type javax.media.jai.util.Range cannot be resolved. It is indirectly referenced from required .class files SelectionRenderer.java /saig-core/src/org/saig/core/renderer2 line 163 Java Problem


El 25 de agosto de 2010 11:50, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:
Hola Sergio:
 
Gracias por responder a mi correo; he seguido las instrucciones del manual para cargar Kosmo desde Eclipse; el error radica en las instrucciones de la página 25 del manual; una vez que cargo el proyecto saig-core, se adjuntan los archivos por default, pero al terminar de construir el workspace aparecen varios errores,  los adjunto en este correo.
 
Espero me pueda ayudar.
 
Gracias!!!
El 25 de agosto de 2010 01:23, Sergio Baños Calvo <[hidden email]> escribió:

Buenos días Susana.

Si puede indicarnos el error que le aparece en Eclipse (mediante una captura de pantalla por ejemplo) podremos ayudarle.

En principio la guía de usuario (salvo la versión exacta de Java a utilizar, que cuando se redactó era una máquina virtual 1.5) es válida para la última distribución de fuentes existentes.

Un cordial saludo,

El 24/08/2010 23:28, Susana Iraiis Delgado Rodriguez escribió:
Hola:
 
Ya consegui instalar el JAI, el problema era la serie de permisos en la red y el equipo de cómputo; estoy siguiendo al pie de la letra el manual de instalación de KOSMO para Eclipse, pero la versión del manual es obsoleta a mi versión de java (1.6), el problema es que al momento de crear el proyecto con el nombre saig-core, una vez que se agregaron al workspace las carpetas de Kosmo, no puedo marcar que el proyecto viene de esa fuente y cuando lo logre me manda un error en la clase com.vividsolutions.jump.workbench, alguien tiene idea de que estoy haciendo mal?

El 24 de agosto de 2010 14:13, Juan Jose Del Toro <[hidden email]> escribió:
Susana;

Cehca este correo
http://www.mail-archive.com/kosmo@.../msg01375.html

El 24 de agosto de 2010 09:54, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:

Buenos días Ingeniero:
 
Le reenvio copia del mensaje que mendé a la lsita de colaboradores kosmo; además para comentarle sobre la instalación de GeoTools, ya se descargó la versión de NetBeans, pero al tratar de instalarla me manda un mesaje donde se indica que el arcuivo esta dañado; trataré de seguir con las instalaciones o quiere que prosiga con lo de CSS; sin màs por el momento procederé a enviar el correo en inglés a Kosmo.
 
Nos vemos luego.

---------- Mensaje reenviado ----------
De: Susana Iraiis Delgado Rodriguez <[hidden email]>
Fecha: 24 de agosto de 2010 09:51
Asunto: INSTALACIÓN KOSMO EN ECLIPSE
Para: [hidden email]



A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.




--
¡Saludos! / Greetings!
Juan José Del Toro M.
[hidden email]
Guadalajara, Jalisco MEXICO


_______________________________________________ Kosmo mailing list [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo



_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo

--

Sergio Baños Calvo

Jefe de desarrollos
Sistemas Abiertos de Información Geográfica, S.L. (SAIG S.L.)
Tlfno. móvil: 685005960
Tlfno. fijo: (+34) 954788876

E-mail: [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo
Reply | Threaded
Open this post in threaded view
|

Re: INSTALACIÓN KOSMO EN ECLIPSE

Susana Iraiis Delgado Rodriguez
Hola de nuevo:
 
Ya cheque la opción que me dices y todo está configurado de manera correcta, como me lo indica. Le adjunto la imagen correspondiente.
 
Muchas gracias, saludos;

El 26 de agosto de 2010 16:16, Sergio Baños Calvo <[hidden email]> escribió:
Buenas de nuevo Susana.

Le comento las dudas planteadas:

1) Una vez que agregó las librerias no tengo el jar CATMEdit.jar que se indica en el manual

La sección correspondiente al jar CATMEdit.jar está obsoleta, dicho jar ya no está incluido en la distribución y no es necesario ordenarlo de la forma indicada en el manual (si era un paso obligatorio en versiones anteriores).


2) Ya que se termina de crear el workspace tengo un error en el paquete  org.saig.jump.widgets.util, clase CheckBoxJListSelectionPanel, en la pantalla de errores aparece

Compruebe que las opciones correspondientes a :

- Windows > Preferences > Java > Compiler > Error/Warnings, sección Generics, estén todos a Warning.

Si está configurado de esta forma y persiste el error, mañana por la mañana compruebo otra posible solución al problema.

Saludos,

El 26/08/2010 22:43, Susana Iraiis Delgado Rodriguez escribió:
Buenas tardes Sergio:
 
En primer lugar muchas gracias por su ayuda, me han sido útiles sus indicaciones. Ya realizé los pasos que me indicó al pie de la letra`:
  • Instalé la versión java 1.6_20 con el jai que me indico. Al configuar en el window>preferences>java>installed JRE se me agregaron por defaults los jars que me había indicado, todo salido bien y configure para el proyecto el JDK que ínstalé. 
  • Al crear el proyecto de acuerdo al manual no tengo la opción de <create project from existing source, pero si carga los archivos.
Mis dudas son:
  • Una vez que agregó las librerias no tengo el jar CATMEdit.jar que se indica en el manual
  • Ya que se termina de crear el workspace tengo un error en el paquete  org.saig.jump.widgets.util, clase CheckBoxJListSelectionPanel, en la pantalla de errores aparece
The method sort(List<T>, Comparator<? super T>) in the type Collections is not applicable for the arguments (List, Comparator<capture#3-of ?>) CheckBoxJListSelectionPanel.java /saig-core/src/org/saig/jump/widgets/util line 285 Java Problem
 
De cualquier forma adjunto imagen del error, gracias por su atención y paciencia
 
El 26 de agosto de 2010 09:17, Sergio Baños Calvo <[hidden email]> escribió:
Buenas tardes Susana.

Le comento una serie de pasos que le recomiendo para configurar correctamente su entorno de desarrollo:

1) Instalar la última versión del JDK de Java: http://www.oracle.com/technetwork/java/javase/downloads/jdk6-jsp-136632.html

Kosmo Desktop 2.0 RC1 funciona con JRE 1.6_03, pero puede desarrollar perfectamente con la última versión de Java disponible (nosotros estamos trabajando ahora mismo con el JDK 1.6_20).

2) Instalar la última versión disponible de JAI (la versión 1.3 para su sistema operativo) de la página https://jai.dev.java.net/binary-builds.html

- Windows: http://download.java.net/media/jai/builds/release/1_1_3/jai-1_1_3-lib-windows-i586-jdk.exe
- Linux: jai-1_1_3-lib-linux-i586-jdk.bin


3) Configurar Eclipse para que use dicho JDK para compilar

- Windows > Preferences > Java > Installed JREs y pulse el botón "Add" para incluir este nuevo JDK. Seleccione el directorio correspondiente a su instalación del JDK.
- Una vez añadido, en el listado de JRE system libraries de la misma pantalla debe incluir dos entradas correspondientes a jai_codec.jar y jai_core.jar (además de otro conjunto de entradas).

Si después de realizar estos pasos sigue quedando algún error comuníquemelo para poder ayudarle.

Saludos,


El 25/08/2010 21:38, Susana Iraiis Delgado Rodriguez escribió:
Hola Sergio:
 
Ya resolví los problemas anteriores, se solucionó mediante la instalación del jar JAI; además de la desinstalación del jdk de java versión 1.6 update 21 por el java versión 1.6 update 3. Ahora el problema que tengo y que se muestra es el siguiente:
 
Description Resource Path Location Type
The project was not built since its build path is incomplete. Cannot find the class file for javax.media.jai.util.Range. Fix the build path then try building this project saig-core  Unknown Java Problem.
 
Description Resource Path Location Type
The type javax.media.jai.util.Range cannot be resolved. It is indirectly referenced from required .class files SelectionRenderer.java /saig-core/src/org/saig/core/renderer2 line 163 Java Problem


El 25 de agosto de 2010 11:50, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:
Hola Sergio:
 
Gracias por responder a mi correo; he seguido las instrucciones del manual para cargar Kosmo desde Eclipse; el error radica en las instrucciones de la página 25 del manual; una vez que cargo el proyecto saig-core, se adjuntan los archivos por default, pero al terminar de construir el workspace aparecen varios errores,  los adjunto en este correo.
 
Espero me pueda ayudar.
 
Gracias!!!
El 25 de agosto de 2010 01:23, Sergio Baños Calvo <[hidden email]> escribió:

Buenos días Susana.

Si puede indicarnos el error que le aparece en Eclipse (mediante una captura de pantalla por ejemplo) podremos ayudarle.

En principio la guía de usuario (salvo la versión exacta de Java a utilizar, que cuando se redactó era una máquina virtual 1.5) es válida para la última distribución de fuentes existentes.

Un cordial saludo,

El 24/08/2010 23:28, Susana Iraiis Delgado Rodriguez escribió:
Hola:
 
Ya consegui instalar el JAI, el problema era la serie de permisos en la red y el equipo de cómputo; estoy siguiendo al pie de la letra el manual de instalación de KOSMO para Eclipse, pero la versión del manual es obsoleta a mi versión de java (1.6), el problema es que al momento de crear el proyecto con el nombre saig-core, una vez que se agregaron al workspace las carpetas de Kosmo, no puedo marcar que el proyecto viene de esa fuente y cuando lo logre me manda un error en la clase com.vividsolutions.jump.workbench, alguien tiene idea de que estoy haciendo mal?

El 24 de agosto de 2010 14:13, Juan Jose Del Toro <[hidden email]> escribió:
Susana;

Cehca este correo
http://www.mail-archive.com/kosmo@.../msg01375.html

El 24 de agosto de 2010 09:54, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:

Buenos días Ingeniero:
 
Le reenvio copia del mensaje que mendé a la lsita de colaboradores kosmo; además para comentarle sobre la instalación de GeoTools, ya se descargó la versión de NetBeans, pero al tratar de instalarla me manda un mesaje donde se indica que el arcuivo esta dañado; trataré de seguir con las instalaciones o quiere que prosiga con lo de CSS; sin màs por el momento procederé a enviar el correo en inglés a Kosmo.
 
Nos vemos luego.

---------- Mensaje reenviado ----------
De: Susana Iraiis Delgado Rodriguez <[hidden email]>
Fecha: 24 de agosto de 2010 09:51
Asunto: INSTALACIÓN KOSMO EN ECLIPSE
Para: [hidden email]



A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.




--
¡Saludos! / Greetings!
Juan José Del Toro M.
[hidden email]
Guadalajara, Jalisco MEXICO


_______________________________________________ Kosmo mailing list [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo



_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo

--

Sergio Baños Calvo

Jefe de desarrollos
Sistemas Abiertos de Información Geográfica, S.L. (SAIG S.L.)
Tlfno. móvil: 685005960
Tlfno. fijo: (+34) 954788876

E-mail: [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo



_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo

generic.JPG (174K) Download Attachment
Reply | Threaded
Open this post in threaded view
|

Re: INSTALACIÓN KOSMO EN ECLIPSE

Sergio Baños Calvo
Buenos días Susana.

La solución al problema que comentas es cambiar en la clase CheckBoxJListSelectionPanel la línea correspondiente a:

private final Comparator<?> comparator;

por:

private final Comparator<? super Object> comparator;

Se trata de un error que detectamos al compilar con Eclipse 3.5.2 (con versiones anteriores no aparecía).

Saludos,

El 26/08/2010 23:31, Susana Iraiis Delgado Rodriguez escribió:
Hola de nuevo:
 
Ya cheque la opción que me dices y todo está configurado de manera correcta, como me lo indica. Le adjunto la imagen correspondiente.
 
Muchas gracias, saludos;

El 26 de agosto de 2010 16:16, Sergio Baños Calvo <[hidden email]> escribió:
Buenas de nuevo Susana.

Le comento las dudas planteadas:

1) Una vez que agregó las librerias no tengo el jar CATMEdit.jar que se indica en el manual

La sección correspondiente al jar CATMEdit.jar está obsoleta, dicho jar ya no está incluido en la distribución y no es necesario ordenarlo de la forma indicada en el manual (si era un paso obligatorio en versiones anteriores).


2) Ya que se termina de crear el workspace tengo un error en el paquete  org.saig.jump.widgets.util, clase CheckBoxJListSelectionPanel, en la pantalla de errores aparece

Compruebe que las opciones correspondientes a :

- Windows > Preferences > Java > Compiler > Error/Warnings, sección Generics, estén todos a Warning.

Si está configurado de esta forma y persiste el error, mañana por la mañana compruebo otra posible solución al problema.

Saludos,

El 26/08/2010 22:43, Susana Iraiis Delgado Rodriguez escribió:
Buenas tardes Sergio:
 
En primer lugar muchas gracias por su ayuda, me han sido útiles sus indicaciones. Ya realizé los pasos que me indicó al pie de la letra`:
  • Instalé la versión java 1.6_20 con el jai que me indico. Al configuar en el window>preferences>java>installed JRE se me agregaron por defaults los jars que me había indicado, todo salido bien y configure para el proyecto el JDK que ínstalé. 
  • Al crear el proyecto de acuerdo al manual no tengo la opción de <create project from existing source, pero si carga los archivos.
Mis dudas son:
  • Una vez que agregó las librerias no tengo el jar CATMEdit.jar que se indica en el manual
  • Ya que se termina de crear el workspace tengo un error en el paquete  org.saig.jump.widgets.util, clase CheckBoxJListSelectionPanel, en la pantalla de errores aparece
The method sort(List<T>, Comparator<? super T>) in the type Collections is not applicable for the arguments (List, Comparator<capture#3-of ?>) CheckBoxJListSelectionPanel.java /saig-core/src/org/saig/jump/widgets/util line 285 Java Problem
 
De cualquier forma adjunto imagen del error, gracias por su atención y paciencia
 
El 26 de agosto de 2010 09:17, Sergio Baños Calvo <[hidden email]> escribió:
Buenas tardes Susana.

Le comento una serie de pasos que le recomiendo para configurar correctamente su entorno de desarrollo:

1) Instalar la última versión del JDK de Java: http://www.oracle.com/technetwork/java/javase/downloads/jdk6-jsp-136632.html

Kosmo Desktop 2.0 RC1 funciona con JRE 1.6_03, pero puede desarrollar perfectamente con la última versión de Java disponible (nosotros estamos trabajando ahora mismo con el JDK 1.6_20).

2) Instalar la última versión disponible de JAI (la versión 1.3 para su sistema operativo) de la página https://jai.dev.java.net/binary-builds.html

- Windows: http://download.java.net/media/jai/builds/release/1_1_3/jai-1_1_3-lib-windows-i586-jdk.exe
- Linux: jai-1_1_3-lib-linux-i586-jdk.bin


3) Configurar Eclipse para que use dicho JDK para compilar

- Windows > Preferences > Java > Installed JREs y pulse el botón "Add" para incluir este nuevo JDK. Seleccione el directorio correspondiente a su instalación del JDK.
- Una vez añadido, en el listado de JRE system libraries de la misma pantalla debe incluir dos entradas correspondientes a jai_codec.jar y jai_core.jar (además de otro conjunto de entradas).

Si después de realizar estos pasos sigue quedando algún error comuníquemelo para poder ayudarle.

Saludos,


El 25/08/2010 21:38, Susana Iraiis Delgado Rodriguez escribió:
Hola Sergio:
 
Ya resolví los problemas anteriores, se solucionó mediante la instalación del jar JAI; además de la desinstalación del jdk de java versión 1.6 update 21 por el java versión 1.6 update 3. Ahora el problema que tengo y que se muestra es el siguiente:
 
Description Resource Path Location Type
The project was not built since its build path is incomplete. Cannot find the class file for javax.media.jai.util.Range. Fix the build path then try building this project saig-core  Unknown Java Problem.
 
Description Resource Path Location Type
The type javax.media.jai.util.Range cannot be resolved. It is indirectly referenced from required .class files SelectionRenderer.java /saig-core/src/org/saig/core/renderer2 line 163 Java Problem


El 25 de agosto de 2010 11:50, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:
Hola Sergio:
 
Gracias por responder a mi correo; he seguido las instrucciones del manual para cargar Kosmo desde Eclipse; el error radica en las instrucciones de la página 25 del manual; una vez que cargo el proyecto saig-core, se adjuntan los archivos por default, pero al terminar de construir el workspace aparecen varios errores,  los adjunto en este correo.
 
Espero me pueda ayudar.
 
Gracias!!!
El 25 de agosto de 2010 01:23, Sergio Baños Calvo <[hidden email]> escribió:

Buenos días Susana.

Si puede indicarnos el error que le aparece en Eclipse (mediante una captura de pantalla por ejemplo) podremos ayudarle.

En principio la guía de usuario (salvo la versión exacta de Java a utilizar, que cuando se redactó era una máquina virtual 1.5) es válida para la última distribución de fuentes existentes.

Un cordial saludo,

El 24/08/2010 23:28, Susana Iraiis Delgado Rodriguez escribió:
Hola:
 
Ya consegui instalar el JAI, el problema era la serie de permisos en la red y el equipo de cómputo; estoy siguiendo al pie de la letra el manual de instalación de KOSMO para Eclipse, pero la versión del manual es obsoleta a mi versión de java (1.6), el problema es que al momento de crear el proyecto con el nombre saig-core, una vez que se agregaron al workspace las carpetas de Kosmo, no puedo marcar que el proyecto viene de esa fuente y cuando lo logre me manda un error en la clase com.vividsolutions.jump.workbench, alguien tiene idea de que estoy haciendo mal?

El 24 de agosto de 2010 14:13, Juan Jose Del Toro <[hidden email]> escribió:
Susana;

Cehca este correo
http://www.mail-archive.com/kosmo@.../msg01375.html

El 24 de agosto de 2010 09:54, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:

Buenos días Ingeniero:
 
Le reenvio copia del mensaje que mendé a la lsita de colaboradores kosmo; además para comentarle sobre la instalación de GeoTools, ya se descargó la versión de NetBeans, pero al tratar de instalarla me manda un mesaje donde se indica que el arcuivo esta dañado; trataré de seguir con las instalaciones o quiere que prosiga con lo de CSS; sin màs por el momento procederé a enviar el correo en inglés a Kosmo.
 
Nos vemos luego.

---------- Mensaje reenviado ----------
De: Susana Iraiis Delgado Rodriguez <[hidden email]>
Fecha: 24 de agosto de 2010 09:51
Asunto: INSTALACIÓN KOSMO EN ECLIPSE
Para: [hidden email]



A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.




--
¡Saludos! / Greetings!
Juan José Del Toro M.
[hidden email]
Guadalajara, Jalisco MEXICO


_______________________________________________ Kosmo mailing list [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo



_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo

--

Sergio Baños Calvo

Jefe de desarrollos
Sistemas Abiertos de Información Geográfica, S.L. (SAIG S.L.)
Tlfno. móvil: 685005960
Tlfno. fijo: (+34) 954788876

E-mail: [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo

--

Sergio Baños Calvo

Jefe de desarrollos
Sistemas Abiertos de Información Geográfica, S.L. (SAIG S.L.)
Tlfno. móvil: 685005960
Tlfno. fijo: (+34) 954788876

E-mail: [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo
Reply | Threaded
Open this post in threaded view
|

Re: INSTALACIÓN KOSMO EN ECLIPSE

Susana Iraiis Delgado Rodriguez
Buen día Sergio:
 
Ya realizé el cambio que me indicaste a la clase CheckBoxJListSelectionPanel; guarde los cambios y me aparecieron 91 errores, porque fallaba la clase LoadTableDialog; lo que  hice fue checar con el puntero el error, y me despliega un mensaje:
 
Syntax error, parameterized types are only available is source level is 1.5, entonces en Window> Preferences> Java> Compiler> JDK Compliance; desmarqué la opción "Use default compliance settings" y en la opción "Source compatibility" cambié 1.6 por 1.5.
 
Hasta este momento ya no me marca ningún error, voy a seguir con los siguientes pasos del manual y si tengo alguna duda, te lo haré saber, gracias.
 
Saludos;
 
El 27 de agosto de 2010 01:17, Sergio Baños Calvo <[hidden email]> escribió:
Buenos días Susana.

La solución al problema que comentas es cambiar en la clase CheckBoxJListSelectionPanel la línea correspondiente a:

private final Comparator<?> comparator;

por:

private final Comparator<? super Object> comparator;

Se trata de un error que detectamos al compilar con Eclipse 3.5.2 (con versiones anteriores no aparecía).

Saludos,

El 26/08/2010 23:31, Susana Iraiis Delgado Rodriguez escribió:
Hola de nuevo:
 
Ya cheque la opción que me dices y todo está configurado de manera correcta, como me lo indica. Le adjunto la imagen correspondiente.
 
Muchas gracias, saludos;

El 26 de agosto de 2010 16:16, Sergio Baños Calvo <[hidden email]> escribió:
Buenas de nuevo Susana.

Le comento las dudas planteadas:

1) Una vez que agregó las librerias no tengo el jar CATMEdit.jar que se indica en el manual

La sección correspondiente al jar CATMEdit.jar está obsoleta, dicho jar ya no está incluido en la distribución y no es necesario ordenarlo de la forma indicada en el manual (si era un paso obligatorio en versiones anteriores).


2) Ya que se termina de crear el workspace tengo un error en el paquete  org.saig.jump.widgets.util, clase CheckBoxJListSelectionPanel, en la pantalla de errores aparece

Compruebe que las opciones correspondientes a :

- Windows > Preferences > Java > Compiler > Error/Warnings, sección Generics, estén todos a Warning.

Si está configurado de esta forma y persiste el error, mañana por la mañana compruebo otra posible solución al problema.

Saludos,

El 26/08/2010 22:43, Susana Iraiis Delgado Rodriguez escribió:
Buenas tardes Sergio:
 
En primer lugar muchas gracias por su ayuda, me han sido útiles sus indicaciones. Ya realizé los pasos que me indicó al pie de la letra`:
  • Instalé la versión java 1.6_20 con el jai que me indico. Al configuar en el window>preferences>java>installed JRE se me agregaron por defaults los jars que me había indicado, todo salido bien y configure para el proyecto el JDK que ínstalé. 
  • Al crear el proyecto de acuerdo al manual no tengo la opción de <create project from existing source, pero si carga los archivos.
Mis dudas son:
  • Una vez que agregó las librerias no tengo el jar CATMEdit.jar que se indica en el manual
  • Ya que se termina de crear el workspace tengo un error en el paquete  org.saig.jump.widgets.util, clase CheckBoxJListSelectionPanel, en la pantalla de errores aparece
The method sort(List<T>, Comparator<? super T>) in the type Collections is not applicable for the arguments (List, Comparator<capture#3-of ?>) CheckBoxJListSelectionPanel.java /saig-core/src/org/saig/jump/widgets/util line 285 Java Problem
 
De cualquier forma adjunto imagen del error, gracias por su atención y paciencia
 
El 26 de agosto de 2010 09:17, Sergio Baños Calvo <[hidden email]> escribió:
Buenas tardes Susana.

Le comento una serie de pasos que le recomiendo para configurar correctamente su entorno de desarrollo:

1) Instalar la última versión del JDK de Java: http://www.oracle.com/technetwork/java/javase/downloads/jdk6-jsp-136632.html

Kosmo Desktop 2.0 RC1 funciona con JRE 1.6_03, pero puede desarrollar perfectamente con la última versión de Java disponible (nosotros estamos trabajando ahora mismo con el JDK 1.6_20).

2) Instalar la última versión disponible de JAI (la versión 1.3 para su sistema operativo) de la página https://jai.dev.java.net/binary-builds.html

- Windows: http://download.java.net/media/jai/builds/release/1_1_3/jai-1_1_3-lib-windows-i586-jdk.exe
- Linux: jai-1_1_3-lib-linux-i586-jdk.bin


3) Configurar Eclipse para que use dicho JDK para compilar

- Windows > Preferences > Java > Installed JREs y pulse el botón "Add" para incluir este nuevo JDK. Seleccione el directorio correspondiente a su instalación del JDK.
- Una vez añadido, en el listado de JRE system libraries de la misma pantalla debe incluir dos entradas correspondientes a jai_codec.jar y jai_core.jar (además de otro conjunto de entradas).

Si después de realizar estos pasos sigue quedando algún error comuníquemelo para poder ayudarle.

Saludos,


El 25/08/2010 21:38, Susana Iraiis Delgado Rodriguez escribió:
Hola Sergio:
 
Ya resolví los problemas anteriores, se solucionó mediante la instalación del jar JAI; además de la desinstalación del jdk de java versión 1.6 update 21 por el java versión 1.6 update 3. Ahora el problema que tengo y que se muestra es el siguiente:
 
Description Resource Path Location Type
The project was not built since its build path is incomplete. Cannot find the class file for javax.media.jai.util.Range. Fix the build path then try building this project saig-core  Unknown Java Problem.
 
Description Resource Path Location Type
The type javax.media.jai.util.Range cannot be resolved. It is indirectly referenced from required .class files SelectionRenderer.java /saig-core/src/org/saig/core/renderer2 line 163 Java Problem


El 25 de agosto de 2010 11:50, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:
Hola Sergio:
 
Gracias por responder a mi correo; he seguido las instrucciones del manual para cargar Kosmo desde Eclipse; el error radica en las instrucciones de la página 25 del manual; una vez que cargo el proyecto saig-core, se adjuntan los archivos por default, pero al terminar de construir el workspace aparecen varios errores,  los adjunto en este correo.
 
Espero me pueda ayudar.
 
Gracias!!!
El 25 de agosto de 2010 01:23, Sergio Baños Calvo <[hidden email]> escribió:

Buenos días Susana.

Si puede indicarnos el error que le aparece en Eclipse (mediante una captura de pantalla por ejemplo) podremos ayudarle.

En principio la guía de usuario (salvo la versión exacta de Java a utilizar, que cuando se redactó era una máquina virtual 1.5) es válida para la última distribución de fuentes existentes.

Un cordial saludo,

El 24/08/2010 23:28, Susana Iraiis Delgado Rodriguez escribió:
Hola:
 
Ya consegui instalar el JAI, el problema era la serie de permisos en la red y el equipo de cómputo; estoy siguiendo al pie de la letra el manual de instalación de KOSMO para Eclipse, pero la versión del manual es obsoleta a mi versión de java (1.6), el problema es que al momento de crear el proyecto con el nombre saig-core, una vez que se agregaron al workspace las carpetas de Kosmo, no puedo marcar que el proyecto viene de esa fuente y cuando lo logre me manda un error en la clase com.vividsolutions.jump.workbench, alguien tiene idea de que estoy haciendo mal?

El 24 de agosto de 2010 14:13, Juan Jose Del Toro <[hidden email]> escribió:
Susana;

Cehca este correo
http://www.mail-archive.com/kosmo@.../msg01375.html

El 24 de agosto de 2010 09:54, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:

Buenos días Ingeniero:
 
Le reenvio copia del mensaje que mendé a la lsita de colaboradores kosmo; además para comentarle sobre la instalación de GeoTools, ya se descargó la versión de NetBeans, pero al tratar de instalarla me manda un mesaje donde se indica que el arcuivo esta dañado; trataré de seguir con las instalaciones o quiere que prosiga con lo de CSS; sin màs por el momento procederé a enviar el correo en inglés a Kosmo.
 
Nos vemos luego.

---------- Mensaje reenviado ----------
De: Susana Iraiis Delgado Rodriguez <[hidden email]>
Fecha: 24 de agosto de 2010 09:51
Asunto: INSTALACIÓN KOSMO EN ECLIPSE
Para: [hidden email]



A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.




--
¡Saludos! / Greetings!
Juan José Del Toro M.
[hidden email]
Guadalajara, Jalisco MEXICO


_______________________________________________ Kosmo mailing list [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo



_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo

--

Sergio Baños Calvo

Jefe de desarrollos
Sistemas Abiertos de Información Geográfica, S.L. (SAIG S.L.)
Tlfno. móvil: 685005960
Tlfno. fijo: (+34) 954788876

E-mail: [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo

--

Sergio Baños Calvo

Jefe de desarrollos
Sistemas Abiertos de Información Geográfica, S.L. (SAIG S.L.)
Tlfno. móvil: 685005960
Tlfno. fijo: (+34) 954788876

E-mail: [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo



_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo
Reply | Threaded
Open this post in threaded view
|

Re: INSTALACIÓN KOSMO EN ECLIPSE

Susana Iraiis Delgado Rodriguez
Hola Sergio, buen día:
 
Le comunico que la instalación de Kosmo desde Eclipse fue un éxito; además del cambio que realizé referente a la opción Window> Preferences> Java> Compiler> JDK Compliance> Source compatiblity; realicé otros cambios al momento de configurar el Run o corrida del proyecto:
  •  Al momento de buscar la clase para correr el proyecto, escribí directamente el nombre de dicha clase com.vividsolutions.jump.workbench.JUMPWorkbench, si se da clic en search, no encuentra dicha clase.
  • Para la pestaña de Arguments, se debe escribir la ruta del workspace que contiene la carpeta .metadata en mi caso:  -plug-in-directory "C:\workspace\.metadata"
De ahí en adelante todas las demás opciones de la configuarción son las mismas.
 
Gracias por su ayuda, espero que esto sirva a otros desarrolladores.
 
Saludos;
 
El 27 de agosto de 2010 10:16, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:
Buen día Sergio:
 
Ya realizé el cambio que me indicaste a la clase CheckBoxJListSelectionPanel; guarde los cambios y me aparecieron 91 errores, porque fallaba la clase LoadTableDialog; lo que  hice fue checar con el puntero el error, y me despliega un mensaje:
 
Syntax error, parameterized types are only available is source level is 1.5, entonces en Window> Preferences> Java> Compiler> JDK Compliance; desmarqué la opción "Use default compliance settings" y en la opción "Source compatibility" cambié 1.6 por 1.5.
 
Hasta este momento ya no me marca ningún error, voy a seguir con los siguientes pasos del manual y si tengo alguna duda, te lo haré saber, gracias.
 
Saludos;
 
El 27 de agosto de 2010 01:17, Sergio Baños Calvo <[hidden email]> escribió:

Buenos días Susana.

La solución al problema que comentas es cambiar en la clase CheckBoxJListSelectionPanel la línea correspondiente a:

private final Comparator<?> comparator;

por:

private final Comparator<? super Object> comparator;

Se trata de un error que detectamos al compilar con Eclipse 3.5.2 (con versiones anteriores no aparecía).

Saludos,

El 26/08/2010 23:31, Susana Iraiis Delgado Rodriguez escribió:
Hola de nuevo:
 
Ya cheque la opción que me dices y todo está configurado de manera correcta, como me lo indica. Le adjunto la imagen correspondiente.
 
Muchas gracias, saludos;

El 26 de agosto de 2010 16:16, Sergio Baños Calvo <[hidden email]> escribió:
Buenas de nuevo Susana.

Le comento las dudas planteadas:

1) Una vez que agregó las librerias no tengo el jar CATMEdit.jar que se indica en el manual

La sección correspondiente al jar CATMEdit.jar está obsoleta, dicho jar ya no está incluido en la distribución y no es necesario ordenarlo de la forma indicada en el manual (si era un paso obligatorio en versiones anteriores).


2) Ya que se termina de crear el workspace tengo un error en el paquete  org.saig.jump.widgets.util, clase CheckBoxJListSelectionPanel, en la pantalla de errores aparece

Compruebe que las opciones correspondientes a :

- Windows > Preferences > Java > Compiler > Error/Warnings, sección Generics, estén todos a Warning.

Si está configurado de esta forma y persiste el error, mañana por la mañana compruebo otra posible solución al problema.

Saludos,

El 26/08/2010 22:43, Susana Iraiis Delgado Rodriguez escribió:
Buenas tardes Sergio:
 
En primer lugar muchas gracias por su ayuda, me han sido útiles sus indicaciones. Ya realizé los pasos que me indicó al pie de la letra`:
  • Instalé la versión java 1.6_20 con el jai que me indico. Al configuar en el window>preferences>java>installed JRE se me agregaron por defaults los jars que me había indicado, todo salido bien y configure para el proyecto el JDK que ínstalé. 
  • Al crear el proyecto de acuerdo al manual no tengo la opción de <create project from existing source, pero si carga los archivos.
Mis dudas son:
  • Una vez que agregó las librerias no tengo el jar CATMEdit.jar que se indica en el manual
  • Ya que se termina de crear el workspace tengo un error en el paquete  org.saig.jump.widgets.util, clase CheckBoxJListSelectionPanel, en la pantalla de errores aparece
The method sort(List<T>, Comparator<? super T>) in the type Collections is not applicable for the arguments (List, Comparator<capture#3-of ?>) CheckBoxJListSelectionPanel.java /saig-core/src/org/saig/jump/widgets/util line 285 Java Problem
 
De cualquier forma adjunto imagen del error, gracias por su atención y paciencia
 
El 26 de agosto de 2010 09:17, Sergio Baños Calvo <[hidden email]> escribió:
Buenas tardes Susana.

Le comento una serie de pasos que le recomiendo para configurar correctamente su entorno de desarrollo:

1) Instalar la última versión del JDK de Java: http://www.oracle.com/technetwork/java/javase/downloads/jdk6-jsp-136632.html

Kosmo Desktop 2.0 RC1 funciona con JRE 1.6_03, pero puede desarrollar perfectamente con la última versión de Java disponible (nosotros estamos trabajando ahora mismo con el JDK 1.6_20).

2) Instalar la última versión disponible de JAI (la versión 1.3 para su sistema operativo) de la página https://jai.dev.java.net/binary-builds.html

- Windows: http://download.java.net/media/jai/builds/release/1_1_3/jai-1_1_3-lib-windows-i586-jdk.exe
- Linux: jai-1_1_3-lib-linux-i586-jdk.bin


3) Configurar Eclipse para que use dicho JDK para compilar

- Windows > Preferences > Java > Installed JREs y pulse el botón "Add" para incluir este nuevo JDK. Seleccione el directorio correspondiente a su instalación del JDK.
- Una vez añadido, en el listado de JRE system libraries de la misma pantalla debe incluir dos entradas correspondientes a jai_codec.jar y jai_core.jar (además de otro conjunto de entradas).

Si después de realizar estos pasos sigue quedando algún error comuníquemelo para poder ayudarle.

Saludos,


El 25/08/2010 21:38, Susana Iraiis Delgado Rodriguez escribió:
Hola Sergio:
 
Ya resolví los problemas anteriores, se solucionó mediante la instalación del jar JAI; además de la desinstalación del jdk de java versión 1.6 update 21 por el java versión 1.6 update 3. Ahora el problema que tengo y que se muestra es el siguiente:
 
Description Resource Path Location Type
The project was not built since its build path is incomplete. Cannot find the class file for javax.media.jai.util.Range. Fix the build path then try building this project saig-core  Unknown Java Problem.
 
Description Resource Path Location Type
The type javax.media.jai.util.Range cannot be resolved. It is indirectly referenced from required .class files SelectionRenderer.java /saig-core/src/org/saig/core/renderer2 line 163 Java Problem


El 25 de agosto de 2010 11:50, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:
Hola Sergio:
 
Gracias por responder a mi correo; he seguido las instrucciones del manual para cargar Kosmo desde Eclipse; el error radica en las instrucciones de la página 25 del manual; una vez que cargo el proyecto saig-core, se adjuntan los archivos por default, pero al terminar de construir el workspace aparecen varios errores,  los adjunto en este correo.
 
Espero me pueda ayudar.
 
Gracias!!!
El 25 de agosto de 2010 01:23, Sergio Baños Calvo <[hidden email]> escribió:

Buenos días Susana.

Si puede indicarnos el error que le aparece en Eclipse (mediante una captura de pantalla por ejemplo) podremos ayudarle.

En principio la guía de usuario (salvo la versión exacta de Java a utilizar, que cuando se redactó era una máquina virtual 1.5) es válida para la última distribución de fuentes existentes.

Un cordial saludo,

El 24/08/2010 23:28, Susana Iraiis Delgado Rodriguez escribió:
Hola:
 
Ya consegui instalar el JAI, el problema era la serie de permisos en la red y el equipo de cómputo; estoy siguiendo al pie de la letra el manual de instalación de KOSMO para Eclipse, pero la versión del manual es obsoleta a mi versión de java (1.6), el problema es que al momento de crear el proyecto con el nombre saig-core, una vez que se agregaron al workspace las carpetas de Kosmo, no puedo marcar que el proyecto viene de esa fuente y cuando lo logre me manda un error en la clase com.vividsolutions.jump.workbench, alguien tiene idea de que estoy haciendo mal?

El 24 de agosto de 2010 14:13, Juan Jose Del Toro <[hidden email]> escribió:
Susana;

Cehca este correo
http://www.mail-archive.com/kosmo@.../msg01375.html

El 24 de agosto de 2010 09:54, Susana Iraiis Delgado Rodriguez <[hidden email]> escribió:

Buenos días Ingeniero:
 
Le reenvio copia del mensaje que mendé a la lsita de colaboradores kosmo; además para comentarle sobre la instalación de GeoTools, ya se descargó la versión de NetBeans, pero al tratar de instalarla me manda un mesaje donde se indica que el arcuivo esta dañado; trataré de seguir con las instalaciones o quiere que prosiga con lo de CSS; sin màs por el momento procederé a enviar el correo en inglés a Kosmo.
 
Nos vemos luego.

---------- Mensaje reenviado ----------
De: Susana Iraiis Delgado Rodriguez <[hidden email]>
Fecha: 24 de agosto de 2010 09:51
Asunto: INSTALACIÓN KOSMO EN ECLIPSE
Para: [hidden email]



A quien corresponda:
 
Hola colaboradores del proyecto KOSMO, escribo desde Guadalajara, Jalisco, México; actualmente me incorporé a un desarrollo de proyección cartográfica donde utilizaremos utilerías de KOSMO.
 
El motivo de mi mail es para preguntar sobre el manual de instalación de KOSMO sobre Eclipse, e seguido todos los pasos que se señalan ahí y me he encontrado con que algunas de las opciones que aparecen en el manual no aparecen en mi IDE; además al tratar de instalar JAI me aparece un mensaje de error cuestionándome sobre la versión de Java.
 
Las herramientas que estoy utilizando son:
  • Java SE version 1.6.0_21 con
  • Java HotSpot TM
  • Kosmo Desktop 2.0_RC1_scr
Mi pregunta es:
  • ¿Tengo que instalar una versión de Java obsoleta a la instalada?
  • ¿Que versión de JAI tengo que instalar?
  • ¿Que versión de KOSMO debo de tener en mi máquina para que sea compatible con las demás herramientas?
Gracias por su atención.




--
¡Saludos! / Greetings!
Juan José Del Toro M.
[hidden email]
Guadalajara, Jalisco MEXICO


_______________________________________________ Kosmo mailing list [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo



_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo

--

Sergio Baños Calvo

Jefe de desarrollos
Sistemas Abiertos de Información Geográfica, S.L. (SAIG S.L.)
Tlfno. móvil: 685005960
Tlfno. fijo: (+34) 954788876

E-mail: [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo


_______________________________________________ Kosmo mailing list [hidden email] http://lists.saig.es/mailman/listinfo/kosmo

--

Sergio Baños Calvo

Jefe de desarrollos
Sistemas Abiertos de Información Geográfica, S.L. (SAIG S.L.)
Tlfno. móvil: 685005960
Tlfno. fijo: (+34) 954788876

E-mail: [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo




_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo