Install mapnik ubuntu 10.04LTS problem

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Install mapnik ubuntu 10.04LTS problem

volterra79
Hi,
i have some problem during mapnik installation process in Ubuntu 10.04LTS
server(64bit).
i receive these error:

apt-get install libmapnik0.7 mapnik-utils python-mapnik
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libmapnik0.7: Depends: libgdal1-1.6.0 but it is not going to be installed
E: Broken packages
root:# apt-get install libmapnik-dev
Reading package lists... Done
Building dependency tree      
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libmapnik-dev: Depends: libmapnik0.7 (= 0.7.0-2ubuntu1) but it is not going
to be installed
                 Depends: libgdal1-dev but it is not going to be installed
                 Depends: libsqlite3-dev but it is not going to be installed
                 Depends: libcurl4-gnutls-dev but it is not going to be
installed
E: Broken packages


How can solve the problem? i have to change my source.list?

Thanks

volterra79
_______________________________________________
Mapnik-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/mapnik-users
Reply | Threaded
Open this post in threaded view
|

Re: Install mapnik ubuntu 10.04LTS problem

Greg Allensworth
It sounds like you're missing a repository. Did you make sure to enable
"universe" in your sources.list file, and then run a "sudo apt-get update" ?

--
Greg Allensworth, Web GIS Developer
BS  A+  Network+  Security+  Linux+  Server+
GreenInfo Network - Information and Mapping in the Public Interest
564 Market Street, Suite 510  San Francisco CA 94104
PH: 415-979-0343 x302  FX: 415-979-0371    email: [hidden email]
Web: www.GreenInfo.org     www.MapsPortal.org

Subscribe to MapLines, our e-newsletter, at www.GreenInfo.org
_______________________________________________
Mapnik-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/mapnik-users
Reply | Threaded
Open this post in threaded view
|

Re: Install mapnik ubuntu 10.04LTS problem

David Paleino-2
In reply to this post by volterra79
On Wed, 8 Feb 2012 15:19:23 +0100 (CET),
[hidden email] wrote:

> Hi,
> i have some problem during mapnik installation process in Ubuntu 10.04LTS
> server(64bit).
> i receive these error:
>
> apt-get install libmapnik0.7 mapnik-utils python-mapnik
> Reading package lists... Done
> Building dependency tree      
> Reading state information... Done
> Some packages could not be installed. This may mean that you have
> requested an impossible situation or if you are using the unstable
> distribution that some required packages have not yet been created
> or been moved out of Incoming.
> The following information may help to resolve the situation:
>
> The following packages have unmet dependencies:
>   libmapnik0.7: Depends: libgdal1-1.6.0 but it is not going to be installed
Can you please run:

  $ apt-cache policy libgdal1-1.6.0

and

  $ apt-cache showsrc gdal | grep Binary

?

Thanks,

--
 . ''`.   Debian developer | http://wiki.debian.org/DavidPaleino
 : :'  : Linuxer #334216 --|-- http://www.hanskalabs.net/
 `. `'`  GPG: 1392B174 ----|---- http://deb.li/dapal
   `-   2BAB C625 4E66 E7B8 450A C3E1 E6AA 9017 1392 B174

_______________________________________________
Mapnik-users mailing list
[hidden email]
https://lists.berlios.de/mailman/listinfo/mapnik-users

signature.asc (205 bytes) Download Attachment