JOSM language plugins and stable version?

classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

JOSM language plugins and stable version?

Florian Schmitt-4
Hi,

it seems that the lang-* plugins aren't available any more. This means that new
users who want to use the "last stable version" 1010 aren't able to change the
language of JOSM. I think as long as a "stable" version is recommended, the
localisation plugins should be available, even if they're not necessary for the
latest build. Would it be possible to provide the lang-Plugins again?

florian

_______________________________________________
josm-dev mailing list
[hidden email]
http://lists.openstreetmap.org/listinfo/josm-dev
Reply | Threaded
Open this post in threaded view
|

Re: JOSM language plugins and stable version?

Dirk Stöcker
On Sun, 2 Nov 2008, Florian Schmitt wrote:

> it seems that the lang-* plugins aren't available any more. This means that new
> users who want to use the "last stable version" 1010 aren't able to change the
> language of JOSM. I think as long as a "stable" version is recommended, the
> localisation plugins should be available, even if they're not necessary for the
> latest build. Would it be possible to provide the lang-Plugins again?

As soon as Frederik fixed the nightly build I would declare that new
version as stable and thus make that problem disappear.

Ciao
--
http://www.dstoecker.eu/ (PGP key available)

_______________________________________________
josm-dev mailing list
[hidden email]
http://lists.openstreetmap.org/listinfo/josm-dev
Reply | Threaded
Open this post in threaded view
|

Re: JOSM language plugins and stable version?

Dirk Stöcker
In reply to this post by Florian Schmitt-4
On Sun, 2 Nov 2008, Florian Schmitt wrote:

> it seems that the lang-* plugins aren't available any more. This means that new
> users who want to use the "last stable version" 1010 aren't able to change the
> language of JOSM. I think as long as a "stable" version is recommended, the
> localisation plugins should be available, even if they're not necessary for the
> latest build. Would it be possible to provide the lang-Plugins again?

I updated the "stable" to 1065.

Ciao
--
http://www.dstoecker.eu/ (PGP key available)

_______________________________________________
josm-dev mailing list
[hidden email]
http://lists.openstreetmap.org/listinfo/josm-dev
Reply | Threaded
Open this post in threaded view
|

Re: JOSM language plugins and stable version?

Stefan Baebler
On Tue, Nov 4, 2008 at 8:28 AM, Dirk Stöcker <[hidden email]> wrote:
> On Sun, 2 Nov 2008, Florian Schmitt wrote:
>
>> it seems that the lang-* plugins aren't available any more. This means that new
>> users who want to use the "last stable version" 1010 aren't able to change the
>> language of JOSM. I think as long as a "stable" version is recommended, the
>> localisation plugins should be available, even if they're not necessary for the
>> latest build. Would it be possible to provide the lang-Plugins again?
>
> I updated the "stable" to 1065.

but this "stable" is also missing translations until build script is
adjusted so that the jar includes translations.

Stefan
_______________________________________________
josm-dev mailing list
[hidden email]
http://lists.openstreetmap.org/listinfo/josm-dev
Reply | Threaded
Open this post in threaded view
|

Re: JOSM language plugins and stable version?

Frederik Ramm
Hi,

Stefan Baebler wrote:
> but this "stable" is also missing translations until build script is
> adjusted so that the jar includes translations.

No:

fred@lochewe:/tmp$ wget -qO-
http://josm.openstreetmap.de/download/josm-tested.jar |jar t|grep Transl
org/openstreetmap/josm/i18n/Translation_de$1.class
org/openstreetmap/josm/i18n/Translation_de.class
org/openstreetmap/josm/i18n/Translation_en_GB$1.class
org/openstreetmap/josm/i18n/Translation_en_GB.class
org/openstreetmap/josm/i18n/Translation_fr$1.class
org/openstreetmap/josm/i18n/Translation_fr.class
org/openstreetmap/josm/i18n/Translation_it$1.class
org/openstreetmap/josm/i18n/Translation_it.class
org/openstreetmap/josm/i18n/Translation_pl$1.class
org/openstreetmap/josm/i18n/Translation_pl.class
org/openstreetmap/josm/i18n/Translation_ro$1.class
org/openstreetmap/josm/i18n/Translation_ro.class
org/openstreetmap/josm/i18n/Translation_ru$1.class
org/openstreetmap/josm/i18n/Translation_ru.class
org/openstreetmap/josm/i18n/Translation_sl$1.class
org/openstreetmap/josm/i18n/Translation_sl.class

Translations are not built automatically (yet) but the ones that are
checked in work.

Bye
Frederik
--
Frederik Ramm  ##  eMail [hidden email]  ##  N49°00'09" E008°23'33"

_______________________________________________
josm-dev mailing list
[hidden email]
http://lists.openstreetmap.org/listinfo/josm-dev
Reply | Threaded
Open this post in threaded view
|

Re: JOSM language plugins and stable version?

Dirk Stöcker
In reply to this post by Stefan Baebler
On Tue, 4 Nov 2008, Stefan Baebler wrote:

> On Tue, Nov 4, 2008 at 8:28 AM, Dirk Stöcker <[hidden email]> wrote:
>> On Sun, 2 Nov 2008, Florian Schmitt wrote:
>>
>>> it seems that the lang-* plugins aren't available any more. This means that new
>>> users who want to use the "last stable version" 1010 aren't able to change the
>>> language of JOSM. I think as long as a "stable" version is recommended, the
>>> localisation plugins should be available, even if they're not necessary for the
>>> latest build. Would it be possible to provide the lang-Plugins again?
>>
>> I updated the "stable" to 1065.
>
> but this "stable" is also missing translations until build script is
> adjusted so that the jar includes translations.
Is it? I downloaded and tested before switching.

Probably you have a yesterdays 1065? :-) Sorry, but there was no change
yesterday, so the number was not increased.

Ciao
--
http://www.dstoecker.eu/ (PGP key available)
_______________________________________________
josm-dev mailing list
[hidden email]
http://lists.openstreetmap.org/listinfo/josm-dev
Reply | Threaded
Open this post in threaded view
|

Re: JOSM language plugins and stable version?

Stefan Baebler
Dirk Stöcker wrote:
>>> I updated the "stable" to 1065.
>> but this "stable" is also missing translations until build script is
>> adjusted so that the jar includes translations.
> Is it? I downloaded and tested before switching.
>
> Probably you have a yesterdays 1065? :-) Sorry, but there was no change
> yesterday, so the number was not increased.
Oops, my bad.

Didn't read all of the mails nor tested again before replying (was
testing all previous days though :D )

Stefan

_______________________________________________
josm-dev mailing list
[hidden email]
http://lists.openstreetmap.org/listinfo/josm-dev