Problemas con la proyecciones configuradas por defecto

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

Problemas con la proyecciones configuradas por defecto

Carlos Lizana

Estimado Sergio Castro Baños:

 

                                        Nuevamente me pongo en contacto con Ustedes para informarles sobre un inconveniente encontrado al abrir un proyecto guardado con un sistema de proyección local. Se trata de la perdida de la referencia al Sistema de Proyección con el que se crean las nuevas vistas en un proyecto. Este problema se observa al recuperar un proyecto que tiene definido (por  defecto)  como sistema de proyección: Campo Inchaupe – Argentina Zona 2  y que contiene más de una vista. Al desplegar las vistas almacenadas, utiliza como proyección: ED50 UTMzone30N, que corresponde a vuestra zona y “olvida”, el sistema con que fueron almacenadas en el proyecto original. Esta situación la he verificado en varios proyectos y sucede que al preguntar por las Propiedades de las distintas Vistas, me informa que están en ED50 UTMzone30N y al pedirle que la cambie a mi sistema de proyección (Campo Inchaupe – Argentina Zona 2), se corrige y se despliega correctamente. Creo que al crear una nueva vista dentro de un proyecto, se genera algún conflicto con el sistema definido por defecto en la configuración inicial. Gracias por vuestro trabajo y como siempre felicitaciones. Ing Carlos Lizana


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo
Reply | Threaded
Open this post in threaded view
|

Re: Problemas con la proyecciones configuradas por defecto

Sergio Baños Calvo
Buenos días Carlos.

He revisado el posible problema en la versión 1.2.1 de Kosmo - Cliente
de escritorio y he sido incapaz de reproducirlo. Recuerde que la
configuración de las vistas por defecto se salva a nivel de aplicación,
es decir, el SRS configurado para la vista por defecto se mantiene para
la misma instancia de la aplicación, pero si carga el proyecto en otra
instalación de Kosmo este valor no se mantiene (salvo que se copie el
fichero de configuración de Kosmo a la otra instalación del programa).
Además, para que se salve la configuración debe cerrarse Kosmo
correctamente, si no el fichero de configuración no se actualiza.

Voy a indicar paso a paso el proceso que he seguido por si acaso me he
equivocado en algún punto:

1) Creo en Kosmo un nuevo proyecto con una vista en un SRS 22192 (Campo
Inchaupe - Argentina Zona 2).
2) Configuro en Fichero > Configuración, Pestaña Avanzadas/Vistas como
SRS por defecto configuro el SRS 22192.
3) Genero 3 vistas nuevas, en cada una de las cuales me da como opción
por defecto el SRS configurado anteriormente.
4) Guardo el proyecto y cierro Kosmo.
5) Abro Kosmo de nuevo, selecciono el proyecto salvado anteriormente y
compruebo que las vistas tienen todas el SRS seleccionado.
6) Genero una nueva vista, de nuevo me aparece por defecto el SRS 22192.

Si los pasos que he dado son correctos y aún así persiste el error en su
instalación, envíenos por favor el fichero kosmo.log situado en el
directorio \bin\logs de su instalación de Kosmo - Cliente de escritorio
para poder tener más datos acerca de qué está pasando.

Un cordial saludo,

Carlos Lizana escribió:

>
> Estimado Sergio Castro Baños:
>
> Nuevamente me pongo en contacto con Ustedes para informarles sobre un
> inconveniente encontrado al abrir un proyecto guardado con un sistema
> de proyección local. Se trata de la perdida de la referencia al
> */Sistema de Proyección/* con el que se crean las nuevas */vistas/* en
> un proyecto. Este problema se observa al recuperar un proyecto que
> tiene definido */(por defecto)/* como sistema de proyección: */Campo
> Inchaupe – Argentina Zona 2 /* y que contiene */más de una vista./* Al
> desplegar las vistas almacenadas, utiliza como proyección: ED50
> UTMzone30N, que corresponde a vuestra zona y */“olvida”/*, el sistema
> con que fueron almacenadas en el proyecto original. Esta situación la
> he verificado en varios proyectos y sucede que al preguntar por las
> Propiedades de las distintas Vistas, me informa que están en ED50
> UTMzone30N y al pedirle que la cambie a mi sistema de proyección
> (Campo Inchaupe – Argentina Zona 2), se corrige y se despliega
> correctamente. Creo que al crear una nueva vista dentro de un
> proyecto, se genera algún conflicto con el sistema definido por
> defecto en la configuración inicial. Gracias por vuestro trabajo y
> como siempre felicitaciones. Ing Carlos Lizana
>
> ------------------------------------------------------------------------
>
> _______________________________________________
> Kosmo mailing list
> [hidden email]
> http://lists.saig.es/mailman/listinfo/kosmo
>  
--

Sergio Baños Calvo

Jefe de desarrollos
Sistemas Abiertos de Información Geográfica, S.L. (SAIG S.L.)
Tlfno. móvil: 685005960
Tlfno. fijo: (+34) 954788876

E-mail: [hidden email]


_______________________________________________
Kosmo mailing list
[hidden email]
http://lists.saig.es/mailman/listinfo/kosmo