Problems with parking area (was Re: newbies Digest, Vol 82, Issue 4)

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Problems with parking area (was Re: newbies Digest, Vol 82, Issue 4)

Marc Gemis
My guess is that the the style of the standard OSM map requires that the parking is represented by a closed line. Note that this is a requirement of that style. Maybe other renderings will show the parking area even if the line is not closed.

Remember not to tag for the renderer, but in this case, you should close the line (first and last point should be the same). otherwise the parking is a line, not an area.

regards

m


On Wed, Jan 8, 2014 at 10:28 PM, <[hidden email]> wrote:
Send newbies mailing list submissions to
        [hidden email]

To subscribe or unsubscribe via the World Wide Web, visit
        https://lists.openstreetmap.org/listinfo/newbies
or, via email, send a message with subject or body 'help' to
        [hidden email]

You can reach the person managing the list at
        [hidden email]

When replying, please edit your Subject line so it is more specific
than "Re: Contents of newbies digest..."


Today's Topics:

   1. Re: newbies Digest, Vol 81, Issue 4 (Fred Felter)


----------------------------------------------------------------------

Message: 1
Date: Wed, 8 Jan 2014 13:28:37 -0800
From: Fred Felter <[hidden email]>
To: [hidden email]
Subject: Re: [OSM-newbies] newbies Digest, Vol 81, Issue 4
Message-ID:
        <CAKmiEzM_S5JWHgsqO=EE4wUjie0ZM=[hidden email]>
Content-Type: text/plain; charset="iso-8859-1"

I am back after a rather lengthy spell of other distractions.

Here is my present problem:
http://www.openstreetmap.org/edit?editor=potlatch2#map=19/44.03350/-123.01851

I have a parking lot delineated from some waypoints I took. The rectangular
shape of the parking lot is visible in Potlach 2 with the parking symbol in
the center and clicking on the edge reveals my WPs but on the OSM map
itself one sees only the "P" symbol, not the yellow shaded areas that
designate parking lots, like ones nearby.
What do I need to do to make the parking lot stand out?
Thanks for any help.
Fred


On Fri, Dec 20, 2013 at 1:58 PM, Fred Felter <[hidden email]> wrote:

> Thanks Ian and Andrew. 2 good response to get me started.
> I have responded to Ian via private OSM email.
> Andrew:
>    The strange appearance is due to its width. The portion I added
> connects a short bridge to the east and a short section to the west that
> already existed. The existing trails that I connected to are lines of
> dashes but my addition is is far more than that. Ian says my addition has a
> bridge tag so I need to review that. I did not add a bridge tag.
>    Is "highway=footway the correct designation for a bike/walking path?
> Seems strange it would not read just "way" instead of "highway". Does that
> yield a line of dashes which I think is what I want?
>    Will I need to use JOSM to fix my addition? It seems quite Imposing for
> me as a novice.
> Fred
>
>
> On Fri, Dec 20, 2013 at 4:00 AM, <[hidden email]>wrote:
>
>> Send newbies mailing list submissions to
>>         [hidden email]
>>
>> To subscribe or unsubscribe via the World Wide Web, visit
>>         https://lists.openstreetmap.org/listinfo/newbies
>> or, via email, send a message with subject or body 'help' to
>>         [hidden email]
>>
>> You can reach the person managing the list at
>>         [hidden email]
>>
>> When replying, please edit your Subject line so it is more specific
>> than "Re: Contents of newbies digest..."
>>
>>
>> Today's Topics:
>>
>>    1. help editing a trail contribution (Fred Felter)
>>    2. Re: help editing a trail contribution (ianmac nz)
>>    3. Re: help editing a trail contribution (Andrew Errington)
>>    4. Re: help editing a trail contribution (Andrew Errington)
>>
>>
>> ----------------------------------------------------------------------
>>
>> Message: 1
>> Date: Thu, 19 Dec 2013 19:31:26 -0800
>> From: Fred Felter <[hidden email]>
>> To: [hidden email]
>> Subject: [OSM-newbies] help editing a trail contribution
>> Message-ID:
>>         <CAKmiEzMURMXw--+taMtjMsuEAmW_465Ldk7=
>> [hidden email]>
>> Content-Type: text/plain; charset="iso-8859-1"
>>
>> My first post here.
>> I recently contributed a GPS trace to complete a foot/bike path near where
>> I live. The result in OSM has a strange appearance and I cannot figure out
>> how to fix it. Since this is new to me I could really use some personal
>> tutoring to get me through this problem. Is this an appropriate forum for
>> that? And if not, where?
>>
>> My trace is http://www.openstreetmap.org/user/frefel/traces/1614067. I
>> wanted my entire trace to be used but only a section was. What I added
>> looks more like a road than a foo/bike trail and I don't see why?
>>
>> Thanks for any help.
>> Fred
>> -------------- next part --------------
>> An HTML attachment was scrubbed...
>> URL: <
>> http://lists.openstreetmap.org/pipermail/newbies/attachments/20131219/7f25ee9b/attachment-0001.html
>> >
>>
>> ------------------------------
>>
>> Message: 2
>> Date: Fri, 20 Dec 2013 11:48:28 +0800
>> From: ianmac nz <[hidden email]>
>> To: Help for newbie mappers <[hidden email]>
>> Subject: Re: [OSM-newbies] help editing a trail contribution
>> Message-ID:
>>         <CAHYGsov4WXssskp0Lm2EcZcL5s2NoAb8ymsQLLEBmPYt=
>> [hidden email]>
>> Content-Type: text/plain; charset="iso-8859-1"
>>
>> Hi
>>
>> You have used the tag bridge=yes for the entire length of the track to the
>> west of the creek crossing.
>>
>> The rendering for bridges looks similar to some roads.
>>
>> Try removing that tag for the west section of the trail.
>>
>> You also need to join the west section of track to the bridge.
>>
>> Hope that helps
>>
>> PS - (tried to send an embedded image but that's not working)
>>
>> Ian
>>
>>
>> On 20 December 2013 11:31, Fred Felter <[hidden email]> wrote:
>>
>> > My first post here.
>> > I recently contributed a GPS trace to complete a foot/bike path near
>> where
>> > I live. The result in OSM has a strange appearance and I cannot figure
>> out
>> > how to fix it. Since this is new to me I could really use some personal
>> > tutoring to get me through this problem. Is this an appropriate forum
>> for
>> > that? And if not, where?
>> >
>> > My trace is http://www.openstreetmap.org/user/frefel/traces/1614067. I
>> > wanted my entire trace to be used but only a section was. What I added
>> > looks more like a road than a foo/bike trail and I don't see why?
>> >
>> > Thanks for any help.
>> > Fred
>> >
>> >
>> > _______________________________________________
>> > newbies mailing list
>> > [hidden email]
>> > https://lists.openstreetmap.org/listinfo/newbies
>> >
>> >
>>
>>
>> --
>> Ian MacIntosh
>> -------------- next part --------------
>> An HTML attachment was scrubbed...
>> URL: <
>> http://lists.openstreetmap.org/pipermail/newbies/attachments/20131220/8eaf49f6/attachment-0001.html
>> >
>>
>> ------------------------------
>>
>> Message: 3
>> Date: Fri, 20 Dec 2013 13:05:57 +0900
>> From: Andrew Errington <[hidden email]>
>> To: Help for newbie mappers <[hidden email]>
>> Subject: Re: [OSM-newbies] help editing a trail contribution
>> Message-ID:
>>         <
>> [hidden email]>
>> Content-Type: text/plain; charset=UTF-8
>>
>> Apologies if I underestimate what you know, but a gps trace will not
>> show up on the map.  We use the gps trace as a guideline to draw roads
>> and trails on the map itself.  It looks like you have done this and
>> drawn a way on top of the trace, and it's tagged highway=footway
>>
>> http://www.openstreetmap.org/way/249319492
>>
>> What is strange about its appearance?  It looks ok.
>>
>> The only thing you can (and should) do is make sure the way is tagged
>> properly.  If you think it is, then you're done.  The way the way (!)
>> is drawn is dependent on the rules for the specific renderer that you
>> are looking at.  If you select a different map layer from the menu on
>> the right you will see your path drawn in a different style (and
>> sometimes not at all).  It's up to the renderer to decide what to
>> render and how to render it.
>>
>> What you *must not do* is alter the tags to make something look the
>> way you want it to on the map.  For example, maybe you'd like a road
>> to be drawn blue (because you like blue), so you could tag it as a
>> river.  It would look blue, but it would be wrongly tagged.  It's an
>> extreme example, but illustrates the point.
>>
>> What do you think needs to be fixed?  If you want the entire trace to
>> be used then you must draw a way along the entire length.  It's
>> possible that somebody else already did some parts of it, so you could
>> re-align the existing ways to your trace, or you could leave them as
>> they are.  Don't forget that the gps trace may be offset by several
>> metres in any direction, so it might not be in exactly the right
>> place.
>>
>> Best wishes,
>>
>> Andrew
>>
>> On 20 December 2013 12:31, Fred Felter <[hidden email]> wrote:
>> > My first post here.
>> > I recently contributed a GPS trace to complete a foot/bike path near
>> where I
>> > live. The result in OSM has a strange appearance and I cannot figure
>> out how
>> > to fix it. Since this is new to me I could really use some personal
>> tutoring
>> > to get me through this problem. Is this an appropriate forum for that?
>> And
>> > if not, where?
>> >
>> > My trace is http://www.openstreetmap.org/user/frefel/traces/1614067. I
>> > wanted my entire trace to be used but only a section was. What I added
>> looks
>> > more like a road than a foo/bike trail and I don't see why?
>> >
>> > Thanks for any help.
>> > Fred
>> >
>> >
>> > _______________________________________________
>> > newbies mailing list
>> > [hidden email]
>> > https://lists.openstreetmap.org/listinfo/newbies
>> >
>>
>>
>>
>> ------------------------------
>>
>> Message: 4
>> Date: Fri, 20 Dec 2013 13:07:10 +0900
>> From: Andrew Errington <[hidden email]>
>> To: Help for newbie mappers <[hidden email]>
>> Subject: Re: [OSM-newbies] help editing a trail contribution
>> Message-ID:
>>         <
>> [hidden email]>
>> Content-Type: text/plain; charset=UTF-8
>>
>> Ah!  Missed the bridge=yes tag!  Other than that it looks fine.
>>
>> On 20 December 2013 13:05, Andrew Errington <[hidden email]> wrote:
>> > Apologies if I underestimate what you know, but a gps trace will not
>> > show up on the map.  We use the gps trace as a guideline to draw roads
>> > and trails on the map itself.  It looks like you have done this and
>> > drawn a way on top of the trace, and it's tagged highway=footway
>> >
>> > http://www.openstreetmap.org/way/249319492
>> >
>> > What is strange about its appearance?  It looks ok.
>> >
>> > The only thing you can (and should) do is make sure the way is tagged
>> > properly.  If you think it is, then you're done.  The way the way (!)
>> > is drawn is dependent on the rules for the specific renderer that you
>> > are looking at.  If you select a different map layer from the menu on
>> > the right you will see your path drawn in a different style (and
>> > sometimes not at all).  It's up to the renderer to decide what to
>> > render and how to render it.
>> >
>> > What you *must not do* is alter the tags to make something look the
>> > way you want it to on the map.  For example, maybe you'd like a road
>> > to be drawn blue (because you like blue), so you could tag it as a
>> > river.  It would look blue, but it would be wrongly tagged.  It's an
>> > extreme example, but illustrates the point.
>> >
>> > What do you think needs to be fixed?  If you want the entire trace to
>> > be used then you must draw a way along the entire length.  It's
>> > possible that somebody else already did some parts of it, so you could
>> > re-align the existing ways to your trace, or you could leave them as
>> > they are.  Don't forget that the gps trace may be offset by several
>> > metres in any direction, so it might not be in exactly the right
>> > place.
>> >
>> > Best wishes,
>> >
>> > Andrew
>> >
>> > On 20 December 2013 12:31, Fred Felter <[hidden email]> wrote:
>> >> My first post here.
>> >> I recently contributed a GPS trace to complete a foot/bike path near
>> where I
>> >> live. The result in OSM has a strange appearance and I cannot figure
>> out how
>> >> to fix it. Since this is new to me I could really use some personal
>> tutoring
>> >> to get me through this problem. Is this an appropriate forum for that?
>> And
>> >> if not, where?
>> >>
>> >> My trace is http://www.openstreetmap.org/user/frefel/traces/1614067. I
>> >> wanted my entire trace to be used but only a section was. What I added
>> looks
>> >> more like a road than a foo/bike trail and I don't see why?
>> >>
>> >> Thanks for any help.
>> >> Fred
>> >>
>> >>
>> >> _______________________________________________
>> >> newbies mailing list
>> >> [hidden email]
>> >> https://lists.openstreetmap.org/listinfo/newbies
>> >>
>>
>>
>>
>> ------------------------------
>>
>> _______________________________________________
>> newbies mailing list
>> [hidden email]
>> https://lists.openstreetmap.org/listinfo/newbies
>>
>>
>> End of newbies Digest, Vol 81, Issue 4
>> **************************************
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.openstreetmap.org/pipermail/newbies/attachments/20140108/b4d9c2a9/attachment.html>

------------------------------

_______________________________________________
newbies mailing list
[hidden email]
https://lists.openstreetmap.org/listinfo/newbies


End of newbies Digest, Vol 82, Issue 4
**************************************


_______________________________________________
newbies mailing list
[hidden email]
https://lists.openstreetmap.org/listinfo/newbies