Re: [udig-users] proble with wms

classic Classic list List threaded Threaded
1 message Options
Reply | Threaded
Open this post in threaded view
|

Re: [udig-users] proble with wms

Jody Garnett-2
I did modify some udig/geotools code to allow the mapfile paramters to be included a while back; there was a bug report.

I tried and was able to connect (capabilities doc parsed, layers listed in the catalog etc...). However I could not get any map displayed.

Logs show the following request being made:

Note that the mapserver capabilities document needs to specify the GetMap operation to include parameters if that is indeed the intended effect. Indeed it looks like that has been done as I see it in the above request.

Jody

On 22/04/2010, at 5:13 PM, Jesse Eichar wrote:

Hi,

This is uDig bug.  The WMS URL cannot have parameters.  So to make this work you would need to create a URL without parameters for example in apache you could make a rewrite rule:

RewriteRule ^/cgi-bin/mapserv.exe/map/(.*)/\?(.*)$ /cgi-bin/mapserv.exe?map=$1&$2 [P]

Something like that should work.  I have not tried it.  The point is the URL cannot have any parameters.  I will try to find a fix for this in uDig but for now this needs to be done.

If you do not have access to the mapserver you can also setup a proxy to that server. 

Sorry for the inconvenience.

Jesse

On Wed, Apr 21, 2010 at 6:41 PM, Luk <[hidden email]> wrote:

Hi,
I'm tring to use a wms service but udig can't render the layer.

With some other wms service from the same provider I have no problem, and
the same service work fine with other QGIS.

Is there anyone that can suggest me where is the problem ?

the wms is:
http://wms.pcn.minambiente.it/cgi-bin/mapserv.exe?map=/ms_ogc/service/ortofoto_alluvione_piemonte_08_f32.map

Thx's
--
View this message in context: http://n2.nabble.com/proble-with-wms-tp4938073p4938073.html
Sent from the udig-users mailing list archive at Nabble.com.
_______________________________________________
udig-users mailing list
[hidden email]
http://lists.refractions.net/mailman/listinfo/udig-users

_______________________________________________
udig-users mailing list
[hidden email]
http://lists.refractions.net/mailman/listinfo/udig-users


_______________________________________________
User-friendly Desktop Internet GIS (uDig)
http://udig.refractions.net
http://lists.refractions.net/mailman/listinfo/udig-devel