Rendering of Cliffs using mapnik-cairo?

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Rendering of Cliffs using mapnik-cairo?

Graham Jones-2
Hi All,
I am working on a service to allow people to create PDF maps of specific areas, with user selectable style features (things like a grid, contours, hillshading, GPX track overlay etc.).
To try to get the best output I am using mapnik's cairo renderer.   At the moment I am using the standard OSM style, but adding my extra layers before rendering.

It is just about working, but I have noticed that something funny happens with the rendering of cliffs - see sample output at: http://maps3.org.uk/printmaps/queueApi/getJobInfo.php?jobNo=33&infoType=3.   
The cliffs are appearing as areas rather than lines.  
They render ok on the main OSM tiles (http://osm.org/go/evnTyCa), but I get the same issue if I use the 'export' function from the OSM site (http://maps3.org.uk/misc/map.pdf).

Therefore I suspect it is something to do with using the cairo backend for mapnik rather than the standard one (agg?), but I am not sure if it is something to do with the OSM style file.

Has anyone else come across this and found a solution?

Thanks


Graham.

--
Graham Jones
Hartlepool, UK.


_______________________________________________
dev mailing list
[hidden email]
http://lists.openstreetmap.org/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Rendering of Cliffs using mapnik-cairo?

nimix
Hi,
I had such isues when using Ubuntus default PDF reader. Have you tried to load your files with adobe reade? That solved the problem for my files. Unfortunately I don't have a pc with the adobe reader right now, where I can try it.
Best Regards,
Melchior
Reply | Threaded
Open this post in threaded view
|

Re: Rendering of Cliffs using mapnik-cairo?

Graham Jones-2
Ah - I think you have got it there, thank you.   The problem goes away if I view the file with xpdf rather than evince - I'll try filing a bug with evince.

Thanks


Graham.

On 18 March 2012 20:15, nimix <[hidden email]> wrote:
Hi,
I had such isues when using Ubuntus default PDF reader. Have you tried to
load your files with adobe reade? That solved the problem for my files.
Unfortunately I don't have a pc with the adobe reader right now, where I can
try it.
Best Regards,
Melchior

--
View this message in context: http://gis.19327.n5.nabble.com/Rendering-of-Cliffs-using-mapnik-cairo-tp5574167p5575603.html
Sent from the Developer Discussion mailing list archive at Nabble.com.

_______________________________________________
dev mailing list
[hidden email]
http://lists.openstreetmap.org/listinfo/dev



--
Graham Jones
Hartlepool, UK.


_______________________________________________
dev mailing list
[hidden email]
http://lists.openstreetmap.org/listinfo/dev