Server configuration: (Urgent problem) pink tiles while requesting lvl 16, 17 & 18 tiles

classic Classic list List threaded Threaded
5 messages Options
Reply | Threaded
Open this post in threaded view
|

Server configuration: (Urgent problem) pink tiles while requesting lvl 16, 17 & 18 tiles

Álvaro Enríquez de Luna Muñoz
Hello, everybody.

I am facing an strange issue. A co-worker set up a tile server for a client by using the instructions on this link:

http://switch2osm.org/serving-tiles/building-a-tile-server-from-packages/

This co-worker isn't working with us anymore, and I am currently facing an urgent problem. Requested tiles from levels 16, 17 and 18 from zones that have never been visited (the app was being used in very restricted areas and now different zones have been enabled) are showing as pink squares. I have read that these kind of requests may fail but they were supposed to be queued and ready to be served after some time. It is not happening. However, zones that users have been using previously, they work just fine (i.e. http://tile.vaivengtc.com/osm/18/126499/102473.png).

You can take a look at the server here:


I have been googling the problem for the whole day and all I found was a firefox bug, which is not my case since it is happening in all the browsers, and this:

https://help.openstreetmap.org/questions/16050/pink-tiles-instead-of-map

which is not my case neither, since the tile's URL seems to be ok.

Since I have never managed this server before, I am scared about making any change because it is a production server, so I need it to be up and running while I solve this problem.

Can someone shed some light on my problem? Maybe pointing out to some helpful link? I would appreciate any help, since I need to solve this issue before next thursday. 

Best regards,

Álvaro Enríquez de Luna Muñoz - CTO
www.many-worlds.es
Phone: +34 675 933 744 / +34 911 298 111



Augmented Reality Technology


_______________________________________________
dev mailing list
[hidden email]
https://lists.openstreetmap.org/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Server configuration: (Urgent problem) pink tiles while requesting lvl 16, 17 & 18 tiles

Andy Allan
On 14 October 2013 17:20, Álvaro Enríquez de Luna Muñoz
<[hidden email]> wrote:

> This co-worker isn't working with us anymore, and I am currently facing an urgent problem. Requested tiles from levels 16, 17 and 18 from zones that have never been visited (the app was being used in very restricted areas and now different zones have been enabled) are showing as pink squares.

Hi there,

It sounds to me like your rendering daemon has died - either renderd,
or tirex, depending on your original setup. Without the rendering
daemon mod_tile will continue to serve tiles that it has rendered
already, but cannot request rendering of any new tiles. The default
appearance of missing tiles on OpenLayers is a (nasty) pink
background, which again sounds like it fits your situation.

Cheers,
Andy

_______________________________________________
dev mailing list
[hidden email]
https://lists.openstreetmap.org/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Server configuration: (Urgent problem) pink tiles while requesting lvl 16, 17 & 18 tiles

Yves
If you can have a look in the tile server (apache ?) error log, you'll probably find some clues.
Look at /var/log/apache2/error.log
Yves


Andy Allan <[hidden email]> a écrit :
On 14 October 2013 17:20, Álvaro Enríquez de Luna Muñoz
<[hidden email]> wrote:

This co-worker isn't working with us anymore, and I am currently facing an urgent problem. Requested tiles from levels 16, 17 and 18 from zones that have never been visited (the app was being used in very restricted areas and now different zones have been enabled) are showing as pink squares.

Hi there,

It sounds to me like your rendering daemon has died - either renderd,
or tirex, depending on your original setup. Without the rendering
daemon mod_tile will continue to serve tiles that it has rendered
already, but cannot request rendering of any new tiles. The default
appearance of missing tiles on OpenLayers is a (nasty) pink
background, which again sounds like it fits your situation.

Cheers,
Andy



dev mailing list
[hidden email]
https://lists.openstreetmap.org/listinfo/dev

--
Envoyé de mon téléphone Android avec K-9 Mail. Excusez la brièveté.
_______________________________________________
dev mailing list
[hidden email]
https://lists.openstreetmap.org/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Server configuration: (Urgent problem) pink tiles while requesting lvl 16, 17 & 18 tiles

Lynn W. Deffenbaugh (Mr)
And search your syslog for any "renderd" entries that might provide other clues.

Lynn (D) - KJ4ERJ - Author of APRSISCE for Windows Mobile and Win32

On 10/14/2013 1:02 PM, Yves wrote:
If you can have a look in the tile server (apache ?) error log, you'll probably find some clues.
Look at /var/log/apache2/error.log
Yves


Andy Allan [hidden email] a écrit :
On 14 October 2013 17:20, Álvaro Enríquez de Luna Muñoz
[hidden email] wrote:

This co-worker isn't working with us anymore, and I am currently facing an urgent problem. Requested tiles from levels 16, 17 and 18 from zones that have never been visited (the app was being used in very restricted areas and now different zones have been enabled) are showing as pink squares.
Hi there, It sounds to me like your rendering daemon has died - either renderd, or tirex, depending on your original setup. Without the rendering daemon mod_tile will continue to serve tiles that it has rendered already, but cannot request rendering of any new tiles. The default appearance of missing tiles on OpenLayers is a (nasty) pink background, which again sounds like it fits your situation. Cheers, Andy
dev mailing list [hidden email] https://lists.openstreetmap.org/listinfo/dev

--
Envoyé de mon téléphone Android avec K-9 Mail. Excusez la brièveté.

_______________________________________________
dev mailing list
[hidden email]
https://lists.openstreetmap.org/listinfo/dev


_______________________________________________
dev mailing list
[hidden email]
https://lists.openstreetmap.org/listinfo/dev
Reply | Threaded
Open this post in threaded view
|

Re: Server configuration: (Urgent problem) pink tiles while requesting lvl 16, 17 & 18 tiles

Robert Scott
In reply to this post by Álvaro Enríquez de Luna Muñoz
On Monday 14 October 2013, Álvaro Enríquez de Luna Muñoz wrote:
> (Urgent problem)

If this really is urgent, I would suggest trying IRC (particularly #osm-dev on OFTC) may get you help quicker.


robert.

_______________________________________________
dev mailing list
[hidden email]
https://lists.openstreetmap.org/listinfo/dev