Strange OSM behaviour...

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

Strange OSM behaviour...

Nick Whitelegg
Have just encountered some slightly strange behaviour from OSM. Tried grabbing
some nodes:

http://www.openstreetmap.org/api/0.2/map?bbox=-1,51,-0.9,51.03

and didn't get anything back, not even a blank <osm version='0.2'></osm>.
There should be some data in that region.

Also when I try out Freemap-OSM (http://www.free-map.org.uk/osm/), which calls
the "map" API above, sometimes it grabs the data and sometimes it doesn't.

Is the server ok?

Nick

_______________________________________________
Openstreetmap mailing list
[hidden email]
http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap
Reply | Threaded
Open this post in threaded view
|

Re: Strange OSM behaviour...

Steve Coast
* @ 23/11/05 09:20:11 PM [hidden email] wrote:

> Have just encountered some slightly strange behaviour from OSM. Tried grabbing
> some nodes:
>
> http://www.openstreetmap.org/api/0.2/map?bbox=-1,51,-0.9,51.03
>
> and didn't get anything back, not even a blank <osm version='0.2'></osm>.
> There should be some data in that region.
>
> Also when I try out Freemap-OSM (http://www.free-map.org.uk/osm/), which calls
> the "map" API above, sometimes it grabs the data and sometimes it doesn't.
>
> Is the server ok?

As far as I know.

I updated the map api to respond with gzip encoding if the request
advertises it as acceptable. commons-httpclient doesn't, annoyingly, so
the applet doesn't benefit.

Do you have any repeatable behaviour? Does libcurl accept gzip-encoding?
I know curl itself doesn't do it. At least by default anyway, I tried
it.

have fun,

SteveC [hidden email] http://www.asklater.com/steve/

_______________________________________________
Openstreetmap mailing list
[hidden email]
http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap
Reply | Threaded
Open this post in threaded view
|

Re: Strange OSM behaviour...

Tommy Persson

> > Is the server ok?
>
> As far as I know.
>

Now the server is not responding at all for me:

URL:http://www.openstreetmap.org/api/0.2/newnode
[hidden email]:++++++* About to connect() to www.openstreetmap.org port 80
*   Trying 128.40.59.140...


/Tommy

_______________________________________________
Openstreetmap mailing list
[hidden email]
http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap
Reply | Threaded
Open this post in threaded view
|

Re: Strange OSM behaviour...

Nick Whitelegg
In reply to this post by Steve Coast
Hello Steve,
>
> Do you have any repeatable behaviour? Does libcurl accept gzip-encoding?

Not sure about that, would need to look it up.

Nick

_______________________________________________
Openstreetmap mailing list
[hidden email]
http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap