Uploaded track has zero points...

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Uploaded track has zero points...

Nick Whitelegg-2


Hello everyone,

Am waiting for the key/value system to be completed before merging the Freemap countryside data with OSM, but in the meantime as
an experiment I thought I'd upload a sample track to OSM. As follows:

<gpx version="1.0" creator="Freemap">
<trk>
<trkseg>
<trkpt lat="51.0470991844" lon="-0.71557632582575">
</trkpt>
<trkpt lat="51.043703932405" lon="-0.71925117610835">
</trkpt>
<trkpt lat="51.04259913827" lon="-0.71938150831769">
</trkpt>
<trkpt lat="51.041802067978" lon="-0.71968880913151">
</trkpt>
<trkpt lat="51.038696159319" lon="-0.7218714018505">
</trkpt>
</trkseg>
</trk>
</gpx>

However OSM reports the track has zero points. How come?

Thanks,
Nick


_______________________________________________
Openstreetmap mailing list
[hidden email]
http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap
Reply | Threaded
Open this post in threaded view
|

RE: Uploaded track has zero points...

ANDY ROBINSON-2
Nick, is it looking for an elevation and timestamp? My gpx files have the
following format:

<?xml version="1.0"?>
<gpx
 version="1.0"
creator="GPSBabel - http://www.gpsbabel.org"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
xmlns="http://www.topografix.com/GPX/1/0"
xsi:schemaLocation="http://www.topografix.com/GPX/1/0
http://www.topografix.com/GPX/1/0/gpx.xsd">
<time>2005-11-07T14:00:09Z</time>
<trk>
  <name>ACTIVE LOG</name>
<trkseg>
<trkpt lat="52.564001083" lon="-1.826841831">
  <ele>115.976196</ele>
<time>2005-11-07T12:03:31Z</time>
</trkpt>
</trkseg>
</trk>
</gpx>


Andy Robinson

> -----Original Message-----
> From: [hidden email] [mailto:openstreetmap-
> [hidden email]] On Behalf Of Nick Whitelegg
> Sent: 07 November 2005 13:26
> To: [hidden email]
> Subject: [Openstreetmap] Uploaded track has zero points...
>
>
>
> Hello everyone,
>
> Am waiting for the key/value system to be completed before merging the
> Freemap countryside data with OSM, but in the meantime as
> an experiment I thought I'd upload a sample track to OSM. As follows:
>
> <gpx version="1.0" creator="Freemap">
> <trk>
> <trkseg>
> <trkpt lat="51.0470991844" lon="-0.71557632582575">
> </trkpt>
> <trkpt lat="51.043703932405" lon="-0.71925117610835">
> </trkpt>
> <trkpt lat="51.04259913827" lon="-0.71938150831769">
> </trkpt>
> <trkpt lat="51.041802067978" lon="-0.71968880913151">
> </trkpt>
> <trkpt lat="51.038696159319" lon="-0.7218714018505">
> </trkpt>
> </trkseg>
> </trk>
> </gpx>
>
> However OSM reports the track has zero points. How come?
>
> Thanks,
> Nick
>
>
> _______________________________________________
> Openstreetmap mailing list
> [hidden email]
> http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap



_______________________________________________
Openstreetmap mailing list
[hidden email]
http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap
Reply | Threaded
Open this post in threaded view
|

Re: Uploaded track has zero points...

Steve Coast
* @ 07/11/05 02:18:16 PM [hidden email] wrote:
> Nick, is it looking for an elevation and timestamp? My gpx files have the
> following format:

ele is optional. Made a FAQ on this. The email you get should be more
descriptive..

http://www.openstreetmap.org/wiki/index.php/FAQ#My_GPX_file_uploaded_with_0_points.3F


> <?xml version="1.0"?>
> <gpx
>  version="1.0"
> creator="GPSBabel - http://www.gpsbabel.org"
> xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
> xmlns="http://www.topografix.com/GPX/1/0"
> xsi:schemaLocation="http://www.topografix.com/GPX/1/0
> http://www.topografix.com/GPX/1/0/gpx.xsd">
> <time>2005-11-07T14:00:09Z</time>
> <trk>
>   <name>ACTIVE LOG</name>
> <trkseg>
> <trkpt lat="52.564001083" lon="-1.826841831">
>   <ele>115.976196</ele>
> <time>2005-11-07T12:03:31Z</time>
> </trkpt>
> </trkseg>
> </trk>
> </gpx>
>
>
> Andy Robinson
>
> > -----Original Message-----
> > From: [hidden email] [mailto:openstreetmap-
> > [hidden email]] On Behalf Of Nick Whitelegg
> > Sent: 07 November 2005 13:26
> > To: [hidden email]
> > Subject: [Openstreetmap] Uploaded track has zero points...
> >
> >
> >
> > Hello everyone,
> >
> > Am waiting for the key/value system to be completed before merging the
> > Freemap countryside data with OSM, but in the meantime as
> > an experiment I thought I'd upload a sample track to OSM. As follows:
> >
> > <gpx version="1.0" creator="Freemap">
> > <trk>
> > <trkseg>
> > <trkpt lat="51.0470991844" lon="-0.71557632582575">
> > </trkpt>
> > <trkpt lat="51.043703932405" lon="-0.71925117610835">
> > </trkpt>
> > <trkpt lat="51.04259913827" lon="-0.71938150831769">
> > </trkpt>
> > <trkpt lat="51.041802067978" lon="-0.71968880913151">
> > </trkpt>
> > <trkpt lat="51.038696159319" lon="-0.7218714018505">
> > </trkpt>
> > </trkseg>
> > </trk>
> > </gpx>
> >
> > However OSM reports the track has zero points. How come?
> >
> > Thanks,
> > Nick
> >
> >
> > _______________________________________________
> > Openstreetmap mailing list
> > [hidden email]
> > http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap
>
>
>
> _______________________________________________
> Openstreetmap mailing list
> [hidden email]
> http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap

have fun,

SteveC [hidden email] http://www.asklater.com/steve/

_______________________________________________
Openstreetmap mailing list
[hidden email]
http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap