osm-editor

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

osm-editor

Steve Coast
the README specs what to install for debian but I get

bartgs47:/home2/steve/svn/osm-editor# apt-get install libqt3-dev libwww-ssl-dev libxmlrpc-c3-dev libcurl3-dev
Reading Package Lists... Done
Building Dependency Tree... Done
Package libqt3-dev is not available, but is referred to by another
package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  libqt3-compat-headers libqt3-headers qt3-dev-tools qt3-qtconfig
qt3-linguist qt3-dev-tools-embedded qt3-dev-tools-compat qt3-designer
qt3-assistant qt3-apps-dev libqt3-mt-dev
E: Package libqt3-dev has no installation candidate


which should be installed?

have fun,

SteveC [hidden email] http://www.asklater.com/steve/

_______________________________________________
Openstreetmap mailing list
[hidden email]
http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap
Reply | Threaded
Open this post in threaded view
|

Re: osm-editor

Jonathan McDowell
On Wed, Nov 23, 2005 at 03:55:25PM +0000, SteveC wrote:

> the README specs what to install for debian but I get
>
> bartgs47:/home2/steve/svn/osm-editor# apt-get install libqt3-dev libwww-ssl-dev libxmlrpc-c3-dev libcurl3-dev
> Reading Package Lists... Done
> Building Dependency Tree... Done
> Package libqt3-dev is not available, but is referred to by another
> package.
> This may mean that the package is missing, has been obsoleted, or
> is only available from another source
> However the following packages replace it:
>   libqt3-compat-headers libqt3-headers qt3-dev-tools qt3-qtconfig
> qt3-linguist qt3-dev-tools-embedded qt3-dev-tools-compat qt3-designer
> qt3-assistant qt3-apps-dev libqt3-mt-dev
> E: Package libqt3-dev has no installation candidate
>
>
> which should be installed?

I have libqt3-mt-dev installed.

J.

--
 General Failure reading drive A:   |       Black Cat Networks Ltd
     Please remove your fist.       | http://www.blackcatnetworks.co.uk/
                                    |  UK Web, domain and email hosting

_______________________________________________
Openstreetmap mailing list
[hidden email]
http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap
Reply | Threaded
Open this post in threaded view
|

Re: osm-editor

Petter Reinholdtsen
In reply to this post by Steve Coast

[Steve Coast]
> the README specs what to install for debian but I get

The README might be outdated.  Try 'debuild' from the devscripts
package, and it will report missing build dependencies based on the
content in debian/control.

Btw, when I have your attention.  It would be more convenient to
package osm-editor/osmeditor if the directory name, the package name
and the program name were the same.  At the moment, both osm-editor
and osmeditor is used.  Could this be changed to use the same all
over?


_______________________________________________
Openstreetmap mailing list
[hidden email]
http://bat.vr.ucl.ac.uk/cgi-bin/mailman/listinfo/openstreetmap