problem starting pitfiller

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|

problem starting pitfiller

Luitpold Hingerl
Hello Andrea,

I don't want to be a bother, so please tell me if I'm asking stupid
questions...
I have loaded a DEM in the esri-asci raster format with this header into
jgrass:
ncols        751
nrows        701
xllcorner    631843.7314101323
yllcorner    5254335.277853666
cellsize     90
nodata_value -9999
Then I run the pitfiller upon this map, which seemed to work, but the
depited map is unfortunately empty, although there was no error message...

I also tried to run the pitfiller with the console, but it can't read
the input map. Here are the console settings and the command:

//Please uncomment and define the following options if needed:
//MAPSET= /home/hingerl/Geotop/jgrass/jgrass/ammersrtm/ammer/
//# GISBASE= opt/grass
//# STARTDATE = 2007-08-03 06:00
//# ENDDATE = 2007-08-06 12:00
//# DELTAT= 30
//# RT= usually not needed
//# DEBUG= false
//# TRACE= false
//# NATIVEDEBUG= false
jgrass h.pitfiller --iesrigrid-elevation ammergridutm.asc
--oesrigrid-pit ammerpit.asc

I'd really appreciate if you'd like to give me some more hints!
Greets from the other side of the alps,

Leo

_______________________________________________
JGrass-users mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users
Reply | Threaded
Open this post in threaded view
|

Re: problem starting pitfiller

Silvia Franceschi-2
Hi Leo,
it seems you didn't set the active region.
To set the active region please take a look here:

http://jgrass.wiki.software.bz.it/jgrass/The_Active_Region

Then for the pitfliller operation:
1. GUI approach: you have also to set the working mapset in the JGrass
menu under the Mapset Settings.

2. script approach:
    // are comments so please uncomment the mapset path and the gisbase
and write the right paths
    if you write jgrass commands on more than one line you have to use
the { so in this case

jgrass {
        h.pitfiller --iesrigrid-elevation ammergridutm.asc
        --oesrigrid-pit ammerpit.asc
        }

Work well,

Silvia

_______________________________________________
JGrass-users mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-users