setup problems

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
16 messages Options
Reply | Threaded
Open this post in threaded view
|

setup problems

gaghi
hi all, i followed the tutorial at http://jgrass.wiki.dev.fsc.bz.it/jgrass/Setup_Development_Environment

I'm sure i checked out those trunks.

Thank in advance.
Regards,
Gabriele Lipari

Reply | Threaded
Open this post in threaded view
|

Re: setup problems

Andrea Antonello
Hi Gabriele,
after a few mails offlist I take this back to list.

> hi all, i followed the tutorial at
> http://jgrass.wiki.dev.fsc.bz.it/jgrass/Setup_Development_Environment
> http://www.nabble.com/file/p17667332/udig%2Bjgrass%2Berror.jpg
> I'm sure i checked out those trunks.

The errors I see are due to missing plugins that are needed for the
console engine and that are from the rcp environment.

The part that describes how to get them is the 1.2.5. JGrass Plugins chapter:
http://jgrass.wiki.dev.fsc.bz.it/jgrass/Setup_Development_Environment#head-8cbee76815b73a88955900d55c31b930698ab73a

You should download them and drop them into teh plugin folder of the
udig target platform. Reload the platform from inside the eclipse
options and the errors should be solved.

Andrea




>
> Thank in advance.
> Regards,
> Gabriele Lipari
>
>
> --
> View this message in context: http://www.nabble.com/setup-problems-tp17667332p17667332.html
> Sent from the JGrass-devel -- Developer list for jgrass mailing list archive at Nabble.com.
>
> _______________________________________________
> JGrass-devel mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
>
_______________________________________________
JGrass-devel mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

gaghi
hi, i tried again follow litterally  the tutorial. I didn't get any result, just always the same errors. Are you sure 100% the tutorial is ok? i'll try again.
thank you
gabriele
Andrea Antonello-3 wrote
Hi Gabriele,
after a few mails offlist I take this back to list.

> hi all, i followed the tutorial at
> http://jgrass.wiki.dev.fsc.bz.it/jgrass/Setup_Development_Environment
> http://www.nabble.com/file/p17667332/udig%2Bjgrass%2Berror.jpg
> I'm sure i checked out those trunks.

The errors I see are due to missing plugins that are needed for the
console engine and that are from the rcp environment.

The part that describes how to get them is the 1.2.5. JGrass Plugins chapter:
http://jgrass.wiki.dev.fsc.bz.it/jgrass/Setup_Development_Environment#head-8cbee76815b73a88955900d55c31b930698ab73a

You should download them and drop them into teh plugin folder of the
udig target platform. Reload the platform from inside the eclipse
options and the errors should be solved.

Andrea




>
> Thank in advance.
> Regards,
> Gabriele Lipari
>
>
> --
> View this message in context: http://www.nabble.com/setup-problems-tp17667332p17667332.html
> Sent from the JGrass-devel -- Developer list for jgrass mailing list archive at Nabble.com.
>
> _______________________________________________
> JGrass-devel mailing list
> JGrass-devel@dev.fsc.bz.it
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
>
_______________________________________________
JGrass-devel mailing list
JGrass-devel@dev.fsc.bz.it
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

Andrea Antonello
> hi, i tried again follow litterally  the tutorial. I didn't get any result,
> just always the same errors. Are you sure 100% the tutorial is ok? i'll try
> again.

Hi Gabriele,
the tutorial is a work in progress which two other guys are writing
up. I am not 100% sure.
But the errors I saw in your screenshots are related to console
plugins missing. Those plugins are in the package that is cited in the
chapter I sent you. So if they are not resolved, probably the target
platform is not setup correctly.

Tomorrow I meet the guy that is writing the tutorial and I will check
together with him.

Andrea


> thank you
> gabriele
>
> Andrea Antonello-3 wrote:
>>
>> Hi Gabriele,
>> after a few mails offlist I take this back to list.
>>
>>> hi all, i followed the tutorial at
>>> http://jgrass.wiki.dev.fsc.bz.it/jgrass/Setup_Development_Environment
>>> http://www.nabble.com/file/p17667332/udig%2Bjgrass%2Berror.jpg
>>> I'm sure i checked out those trunks.
>>
>> The errors I see are due to missing plugins that are needed for the
>> console engine and that are from the rcp environment.
>>
>> The part that describes how to get them is the 1.2.5. JGrass Plugins
>> chapter:
>> http://jgrass.wiki.dev.fsc.bz.it/jgrass/Setup_Development_Environment#head-8cbee76815b73a88955900d55c31b930698ab73a
>>
>> You should download them and drop them into teh plugin folder of the
>> udig target platform. Reload the platform from inside the eclipse
>> options and the errors should be solved.
>>
>> Andrea
>>
>>
>>
>>
>>>
>>> Thank in advance.
>>> Regards,
>>> Gabriele Lipari
>>>
>>>
>>> --
>>> View this message in context:
>>> http://www.nabble.com/setup-problems-tp17667332p17667332.html
>>> Sent from the JGrass-devel -- Developer list for jgrass mailing list
>>> archive at Nabble.com.
>>>
>>> _______________________________________________
>>> JGrass-devel mailing list
>>> [hidden email]
>>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
>>>
>> _______________________________________________
>> JGrass-devel mailing list
>> [hidden email]
>> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
>>
>>
>
> --
> View this message in context: http://www.nabble.com/setup-problems-tp17667332p17675578.html
> Sent from the JGrass-devel -- Developer list for jgrass mailing list archive at Nabble.com.
>
> _______________________________________________
> JGrass-devel mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
>
_______________________________________________
JGrass-devel mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

iomeneandrei
Hi Andrea,

Andrea Antonello-3 wrote
Hi Gabriele,
the tutorial is a work in progress which two other guys are writing
up. I am not 100% sure.
once again thank you for the wiki work. I have tried too to setup the development environment and running jgrass in windows. I have no problem to run uDig (point 5 of the wiki), but I'm not sure to be able to run properly JGRASS.

In the wiki instructions I can read that it's necessary to change the target platform. There is a screenshot and it's seems it's necessary to select only the udik-sdk/plugins folder and deselect the eclipse plugin and jgrass-extra-sdk plugin folders. It seems to me strange to be necessary to deselect this last folder to run JGrass. Am I wrong? Moreover if I deselect jgrass-extra-sdk plugin folder, I will obtain a uDig in which I can not add a JGrass Database Layer.

Then there are the instructions to install subclipse and to set SVN for JGRASS. I have run it, without problem.

I have svn set, and I chose jgrass-extra-sdk plugin and udik-sdk/plugins folders as target platform, and finally I have clicked on run button.
I have obtained a running uDig, and I have the possibility to add JGRASS database layer, but I do not have the jgrass console button.
I think I must setup grass environment using udig grass/console preferences. Do I must download some specific version of grass for windows? Is there some specific installations instructions?

Thank you,

a

Andrea Borruso

----------------------------------------------------
email: aborruso@tin.it
website: http://blog.spaziogis.it
my 2.0 life: http://aborruso.spaziogis.it
feed: http://feeds2.feedburner.com/Tanto
38° 7' 48" N, 13° 21' 9" E
----------------------------------------------------
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

Andrea Antonello
[...]
> I have svn set, and I chose jgrass-extra-sdk plugin and udik-sdk/plugins
> folders as target platform, and finally I have clicked on run button.
> I have obtained a running uDig, and I have the possibility to add JGRASS
> database layer, but I do not have the jgrass console button.
> I think I must setup grass environment using udig grass/console preferences.
> Do I must download some specific version of grass for windows? Is there some
> specific installations instructions?

Hi Andrea,
the toolbars are undergoing some changes lately, also due to a
reordering from the udig side.

The console button should be in a menu, the tools menu, which at the
moment lies wrong after the help item (udig developers are currently
solving that).

Let me know if you find it.

Anyway, following what you are telling me, you were able to run JGrass
following the tutorial, right?
That sounds good. Also if you have proposals and even changes to do
yourself, subscribe to the wiki and feel free to do so.

Ciao
Andrea


>
> Thank you,
>
> a
>
>
>
> -----
> Andrea Borruso
>
> ----------------------------------------------------
> email: [hidden email]
> blog: http://blog.spaziogis.it
> ----------------------------------------------------
> --
> View this message in context: http://www.nabble.com/setup-problems-tp17667332p17688247.html
> Sent from the JGrass-devel -- Developer list for jgrass mailing list archive at Nabble.com.
>
> _______________________________________________
> JGrass-devel mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
>
_______________________________________________
JGrass-devel mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

Daniele Andreis
In reply to this post by iomeneandrei


2008/6/6 iomeneandrei <[hidden email]>:
 I have no problem to run uDig (point 5 of the wiki), but I'm not sure to be able to run properly
JGRASS.

In the wiki instructions I can read that it's necessary to change the target
platform. There is a screenshot and it's seems it's necessary to select only
the udik-sdk/plugins folder and deselect the eclipse plugin and
jgrass-extra-sdk plugin folders. It seems to me strange to be necessary to
deselect this last folder to run JGrass. Am I wrong? Moreover if I deselect
jgrass-extra-sdk plugin folder, I will obtain a uDig in which I can not add
a JGrass Database Layer.
 
Hi,
You're right. You should be check the jgrass-extra-sdk pluig-in folder, it contains eclipse plug-ins. I have changed the first step in the running java chapter.
Thank you





 


--
Daniele Andreis
_______________________________________________
JGrass-devel mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

iomeneandrei
In reply to this post by Andrea Antonello
Hi Andrea,
Andrea Antonello-3 wrote
The console button should be in a menu, the tools menu, which at the
moment lies wrong after the help item (udig developers are currently
solving that).
I do not find the tools menu (I'm attaching a screenshot). Do you have some advice for us?

What about grass configuration?

Thank you,

andrea

jgrass.png
Andrea Borruso

----------------------------------------------------
email: aborruso@tin.it
website: http://blog.spaziogis.it
my 2.0 life: http://aborruso.spaziogis.it
feed: http://feeds2.feedburner.com/Tanto
38° 7' 48" N, 13° 21' 9" E
----------------------------------------------------
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

Andrea Antonello
>> The console button should be in a menu, the tools menu, which at the
>> moment lies wrong after the help item (udig developers are currently
>> solving that).
>>
>
> I do not find the tools menu (I'm attaching a screenshot). Do you have some
> advice for us?

Yes sure, that is an issue we will have to address at some point, you
first have to load a map, to activate those menus.  You could also
just drag the legend in the map part.

> What about grass configuration?

Good you asked, I forgot...

> I think I must setup grass environment using udig grass/console preferences.
> Do I must download some specific version of grass for windows? Is there some
> specific installations instructions?

If you use windows, the eu.hydrologis.jgrass.grass plugin should
contain a folder with inside of it:

windows/grass

and inside that:

    |____ bin
    |____ grass (this is what JGrass will take as the gisbase)
    |       |______ bin
    |       |______ etc
    |       |______ and so on...
    |
    |____ share


I put grass for windows in the packages I released, but not in the
svn, because it is a binary thing.

I wanted to link you to were to download the last native grass package
but I noticed, that they changed it:
http://grass.osgeo.org/grass63/binary/mswindows/native/
So I will have to see what is in the package and test it again :(

For now you should just take the package from a downloaded jgrass
ersion to make it work with commands.


Andrea



>
> Thank you,
>
> andrea
>
> http://www.nabble.com/file/p17689679/jgrass.png jgrass.png
>
> -----
> Andrea Borruso
>
> ----------------------------------------------------
> email: [hidden email]
> blog: http://blog.spaziogis.it
> ----------------------------------------------------
> --
> View this message in context: http://www.nabble.com/setup-problems-tp17667332p17689679.html
> Sent from the JGrass-devel -- Developer list for jgrass mailing list archive at Nabble.com.
>
> _______________________________________________
> JGrass-devel mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
>
_______________________________________________
JGrass-devel mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

iomeneandrei
Hi Andrea,
it's really a pleasure to write in this list. You and your collaborators are very kind.

Andrea Antonello-3 wrote
Yes sure, that is an issue we will have to address at some point, you
first have to load a map, to activate those menus.  You could also
just drag the legend in the map part.
I have loaded a map and added a legend, but I do not have any menu added (I'm attaching a screenshot).

ciao,

a

jgrass2.png
Andrea Borruso

----------------------------------------------------
email: aborruso@tin.it
website: http://blog.spaziogis.it
my 2.0 life: http://aborruso.spaziogis.it
feed: http://feeds2.feedburner.com/Tanto
38° 7' 48" N, 13° 21' 9" E
----------------------------------------------------
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

Andrea Antonello
> Hi Andrea,
> it's really a pleasure to write in this list. You and your collaborators are
> very kind.

Thanks a lot. You know, it is also a pleasure to help users that take
the time to send full reports and screenshots.
That is what I call testing :)

>> Yes sure, that is an issue we will have to address at some point, you
>> first have to load a map, to activate those menus.  You could also
>> just drag the legend in the map part.
>>
>>
>
> I have loaded a map and added a legend, but I do not have any menu added
> (I'm attaching a screenshot).

Hmmm, I see, it is not there. I can't understand what is going on,
since even if there is no tools menu with the console, at least there
should be a udig one with the stop rendering button (if I recall
correctly). What version of udig sdk are you using?

To summarize:
- you are launching udig from eclipse, right?
- you have the jgrass plugins in the workspace (could you send a list
or a screenshot to check if I see something strange)
- you have enabled all the plugins in the run configuration?

Could you check these points for me please?

If it loads grass workspaces but doesn't have the console, perhaps
something is disabled somewhere.

Ciao
Andrea


>
> ciao,
>
> a
>
> http://www.nabble.com/file/p17694955/jgrass2.png jgrass2.png
>
> -----
> Andrea Borruso
>
> ----------------------------------------------------
> email: [hidden email]
> blog: http://blog.spaziogis.it
> ----------------------------------------------------
> --
> View this message in context: http://www.nabble.com/setup-problems-tp17667332p17694955.html
> Sent from the JGrass-devel -- Developer list for jgrass mailing list archive at Nabble.com.
>
> _______________________________________________
> JGrass-devel mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
>
_______________________________________________
JGrass-devel mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

iomeneandrei
Hi Andrea
Andrea Antonello-3 wrote
What version of udig sdk are you using?

To summarize:
- you are launching udig from eclipse, right?
- you have the jgrass plugins in the workspace (could you send a list
or a screenshot to check if I see something strange)
- you have enabled all the plugins in the run configuration?

Could you check these points for me please?

If it loads grass workspaces but doesn't have the console, perhaps
something is disabled somewhere.
I have udig-1.1-RC14-sdk.zip and I launch udig from eclipse.
I have all the plugins active as you can see in the attached file "jgrass3.png".
I think I have jgrass plugins in the workspace because I have the possibility to add a JGrass database layer.
I'm attaching also my folders structure.

Thank you,

Andrea

folder_structure.zip

jgrass3.png
Andrea Borruso

----------------------------------------------------
email: aborruso@tin.it
website: http://blog.spaziogis.it
my 2.0 life: http://aborruso.spaziogis.it
feed: http://feeds2.feedburner.com/Tanto
38° 7' 48" N, 13° 21' 9" E
----------------------------------------------------
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

iomeneandrei
In reply to this post by Andrea Antonello
Hi Andrea,

Andrea Antonello-3 wrote
Thanks a lot. You know, it is also a pleasure to help users that take
the time to send full reports and screenshots.
That is what I call testing :)
only to know you have had the time to read my last messagge related to jgrass compiling.

ciao,

a
Andrea Borruso

----------------------------------------------------
email: aborruso@tin.it
website: http://blog.spaziogis.it
my 2.0 life: http://aborruso.spaziogis.it
feed: http://feeds2.feedburner.com/Tanto
38° 7' 48" N, 13° 21' 9" E
----------------------------------------------------
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

Andrea Antonello
>> Thanks a lot. You know, it is also a pleasure to help users that take
>> the time to send full reports and screenshots.
>> That is what I call testing :)
>>
>
> only to know you have had the time to read my last messagge related to
> jgrass compiling.

Hi Andrea,
the fact that you do not have the console but are able to load jgrass
layers, is for sure due to the fact, that your environment doesn't
load the extra jgrass plugins. Could you please try to copy those
plugins into the plugins folder of the udig-sdk you are using? Then
reload the target platform to make sure they are seen. I have a doubt
that eclipse doesn't load the target platform properly. I usually do
this to have one single sdk.

Let me know,
Andrea

>
> ciao,
>
> a
>
> -----
> Andrea Borruso
>
> ----------------------------------------------------
> email: [hidden email]
> blog: http://blog.spaziogis.it
> ----------------------------------------------------
> --
> View this message in context: http://www.nabble.com/setup-problems-tp17667332p17773281.html
> Sent from the JGrass-devel -- Developer list for jgrass mailing list archive at Nabble.com.
>
> _______________________________________________
> JGrass-devel mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
>
_______________________________________________
JGrass-devel mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

iomeneandrei
Ciao Andrea,

Andrea Antonello-3 wrote
 Could you please try to copy those
plugins into the plugins folder of the udig-sdk you are using? Then
reload the target platform to make sure they are seen.
now I have the jgrass console, thank you.

all the best,

a

Andrea Borruso

----------------------------------------------------
email: aborruso@tin.it
website: http://blog.spaziogis.it
my 2.0 life: http://aborruso.spaziogis.it
feed: http://feeds2.feedburner.com/Tanto
38° 7' 48" N, 13° 21' 9" E
----------------------------------------------------
Reply | Threaded
Open this post in threaded view
|

Re: setup problems

Andrea Antonello
>>  Could you please try to copy those
>> plugins into the plugins folder of the udig-sdk you are using? Then
>> reload the target platform to make sure they are seen.
>>
>
> now I have the jgrass console, thank you.

Great, next week I will spend some time on trying to ease the way to
setup all this without problems. Keep your fingers crossed...

Andrea



>
> all the best,
>
> a
>
> http://www.nabble.com/file/p17794672/jgrass.png
>
> -----
> Andrea Borruso
>
> ----------------------------------------------------
> email: [hidden email]
> blog: http://blog.spaziogis.it
> ----------------------------------------------------
> --
> View this message in context: http://www.nabble.com/setup-problems-tp17667332p17794672.html
> Sent from the JGrass-devel -- Developer list for jgrass mailing list archive at Nabble.com.
>
> _______________________________________________
> JGrass-devel mailing list
> [hidden email]
> https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel
>
_______________________________________________
JGrass-devel mailing list
[hidden email]
https://dev.fsc.bz.it/cgi-bin/mailman/listinfo/jgrass-devel