shape file does not open in layers area

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
7 messages Options
Reply | Threaded
Open this post in threaded view
|

shape file does not open in layers area

randa.alharbi
Hi

I am working on an assignment and I am trying to add a new layer to uDig: a polygon shape file

but when I click on: Layer>add Layer>Select files (add polygon.shp dataset)

the shapefile does not appear and only shows in the project area



how could I add it as a layer in the layer area and viewer area like this:



PLEASE help
Reply | Threaded
Open this post in threaded view
|

Re: shape file does not open in layers area

randa.alharbi
could be that something is wrong with the data?

this is the shapefile I am trying to open:

Reply | Threaded
Open this post in threaded view
|

Re: shape file does not open in layers area

fgdrf
Questions:
* which version of udig are you using? What's the host Operating system? 32/64bit?

Two ideas:
* The shapefile projection (*.prj) is not correct or the projection is unknown.
* do you have read/write access to the folder and containing files? 

Could you provide these polygon files to test in other environments?
Is the Shapefile show in the Catalog view? Have a look into the log file, maybe an Exception occurred but were not shown in the UI.

- Frank


2013/10/11 randa.alharbi <[hidden email]>
could be that something is wrong with the data?

this is the shapefile I am trying to open:

<http://gis.19327.n5.nabble.com/file/n5781068/Capture2.jpg>



--
View this message in context: http://gis.19327.n5.nabble.com/shape-file-does-not-open-in-layers-area-tp5781067p5781068.html
Sent from the uDig Users mailing list archive at Nabble.com.
_______________________________________________
udig-users mailing list
[hidden email]
http://lists.refractions.net/mailman/listinfo/udig-users


_______________________________________________
udig-users mailing list
[hidden email]
http://lists.refractions.net/mailman/listinfo/udig-users
Reply | Threaded
Open this post in threaded view
|

Re: shape file does not open in layers area

Andrea Antonello
Randa, try to use a path without special characters.
I see symbols like commas, & and many other things :)

Try first to use a "clean" path.

Andrea

On Fri, Oct 11, 2013 at 8:52 AM, Frank Gasdorf
<[hidden email]> wrote:

> Questions:
> * which version of udig are you using? What's the host Operating system?
> 32/64bit?
>
> Two ideas:
> * The shapefile projection (*.prj) is not correct or the projection is
> unknown.
> * do you have read/write access to the folder and containing files?
>
> Could you provide these polygon files to test in other environments?
> Is the Shapefile show in the Catalog view? Have a look into the log file,
> maybe an Exception occurred but were not shown in the UI.
>
> - Frank
>
>
> 2013/10/11 randa.alharbi <[hidden email]>
>>
>> could be that something is wrong with the data?
>>
>> this is the shapefile I am trying to open:
>>
>> <http://gis.19327.n5.nabble.com/file/n5781068/Capture2.jpg>
>>
>>
>>
>> --
>> View this message in context:
>> http://gis.19327.n5.nabble.com/shape-file-does-not-open-in-layers-area-tp5781067p5781068.html
>>
>> Sent from the uDig Users mailing list archive at Nabble.com.
>> _______________________________________________
>> udig-users mailing list
>> [hidden email]
>> http://lists.refractions.net/mailman/listinfo/udig-users
>
>
>
> _______________________________________________
> udig-users mailing list
> [hidden email]
> http://lists.refractions.net/mailman/listinfo/udig-users
>
_______________________________________________
udig-users mailing list
[hidden email]
http://lists.refractions.net/mailman/listinfo/udig-users
Reply | Threaded
Open this post in threaded view
|

Re: shape file does not open in layers area

randa.alharbi
yep that was the problem, I changed the path and it worked nicely

thank you
Reply | Threaded
Open this post in threaded view
|

Re: shape file does not open in layers area

randa.alharbi
In reply to this post by fgdrf
Thank you for your reply the problem was with the special charecters I used in file path

Reply | Threaded
Open this post in threaded view
|

Re: shape file does not open in layers area

randa.alharbi
In reply to this post by randa.alharbi
Well we test with the sample data provided for our quick start.

 Look at your screen I see a very strange folder name, with a "," in it. Try going for a very simple folder name and see if that helps.

 A couple other things to try:

 1) open up the entry in the catalog, right click on the features in side and choose "Operations -> Resource Summary"

 2) Finally you can look in the help menu (Help -> Submit Issue). The provided error log will say something like "file not found" which may provide a clue.
 --
 Jody Garnett