wmt plugin doesnt work

Previous Topic Next Topic
 
classic Classic list List threaded Threaded
4 messages Options
Reply | Threaded
Open this post in threaded view
|

wmt plugin doesnt work

obindel1
This post has NOT been accepted by the mailing list yet.
Hi,

iam trying to use a wmt layer in the rcp tutorial application. i can select it in the add layer dialog but after choosing for example a osm tile server, it doesnt show anything on the map. There is no exception thrown.
wms layer and shapefile are working...


i just get this on startup of the app

WARNUNG: Failed to load the GDAL native libs....
WARNUNG: Failed to load the Kakadu native libs....
and
!MESSAGE Problems occurred when invoking code from plug-in: "org.eclipse.ui.workbench".
!STACK 0
java.lang.NullPointerException
        at org.eclipse.core.internal.runtime.Activator.getURLConverter(Activator.java:313)
Reply | Threaded
Open this post in threaded view
|

Re: wmt plugin doesnt work

obindel1
This post has NOT been accepted by the mailing list yet.
oh i deleted a previous post (with answers) because i didnt see any replys and the pending msg for 1 or 2 weeks.


here is the stacktrace i get on startup  

java.lang.NullPointerException
        at org.eclipse.core.internal.runtime.Activator.getURLConverter(Activator.java:313)
        at org.eclipse.core.runtime.FileLocator.toFileURL(FileLocator.java:205)
        at net.refractions.udig.style.sld.editor.CustomPalettesLoader.earlyStartup(CustomPalettesLoader.java:49)
        at org.eclipse.ui.internal.EarlyStartupRunnable.runEarlyStartup(EarlyStartupRunnable.java:87)
        at org.eclipse.ui.internal.EarlyStartupRunnable.run(EarlyStartupRunnable.java:66)
        at org.eclipse.core.runtime.SafeRunner.run(SafeRunner.java:42)
        at org.eclipse.ui.internal.Workbench$59.run(Workbench.java:2409)
        at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)



to add a wmt layer, i use the add layer wizard ..then i choose a openstreetmap server from the list. (this works for me with the installed udig) but not in my rcp app
Reply | Threaded
Open this post in threaded view
|

Re: wmt plugin doesnt work

obindel1
This post has NOT been accepted by the mailing list yet.
i am trying to add this one :   URL url = new URL(null,"wmt://localhost/wmt/net.refractions.udig.catalog.internal.wmt.wmtsource.OSMMapnikSource", CorePlugin.RELAXED_HANDLER);


btw this list is confusing me.. my posts are always pending and i can only see answers on http://lists.refractions.net/    found with google .

Reply | Threaded
Open this post in threaded view
|

Re: wmt plugin doesnt work

obindel1
This post has NOT been accepted by the mailing list yet.
problem solved. i had to delete the plugin folders and reimport the plugin in eclipse. strange.